Edgewall Software
Modify

Opened 4 years ago

Closed 3 years ago

#12428 closed enhancement (duplicate)

Log stacktrace from exceptions when generating navigation items

Reported by: Ryan J Ollos Owned by: Christian Boos
Priority: normal Milestone:
Component: web frontend Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

Suggested in comment:13:ticket:12385, the stacktrace should be logged when an exception occurs generating navigation items: tags/trac-1.0.10/trac/web/chrome.py@:811-816#L809.

Also, we should consider logging the stacktrace when rendering the template (comment:16:ticket:12385): tags/trac-1.0.10/trac/web/chrome.py@:1130-1133#L1108. The stacktrace is printed when use_chunked_encoding: tags/trac-1.0.10/trac/web/chrome.py@:1188-1190#L1165. However, there may be a reason this was not done (comment:18:ticket:12385).

Attachments (0)

Change History (3)

comment:1 by Ryan J Ollos, 3 years ago

Milestone: next-stable-1.0.xnext-stable-1.2.x

Moved ticket assigned to next-stable-1.0.x since maintenance of 1.0.x is coming to a close. Please move the ticket back if it's critical to fix on 1.0.x.

comment:2 by Christian Boos, 3 years ago

Milestone: next-stable-1.2.xnext-dev-1.3.x
Owner: set to Christian Boos
Status: newassigned

Depends on #12680.

comment:3 by Ryan J Ollos, 3 years ago

Milestone: next-dev-1.3.x
Resolution: duplicate
Status: assignedclosed

Duplicate of #12768, which has a proposed patch. We can refactor in #12680.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.