Edgewall Software
Modify

Opened 5 years ago

Closed 4 years ago

#12371 closed defect (worksforme)

AttributeError: 'list' object has no attribute 'find'

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: normal Milestone:
Component: query system Version: 1.0.10
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

From the logs:

016-02-22 07:45:57,348 Trac[main] ERROR: Internal Server Error: <RequestWithSession "GET '/query?status=closed&amp;component=DoxygenPlugin&amp;type=enhancement&amp;group=resolution&amp;max=0&amp;desc=1&amp;order=id'">, referrer None
Traceback (most recent call last):
  File "/srv/trac-hacks.org/pve/lib/python2.7/site-packages/trac/web/main.py", line 554, in _dispatch_request
    dispatcher.dispatch(req)
  File "/srv/trac-hacks.org/pve/lib/python2.7/site-packages/trac/web/main.py", line 267, in dispatch
    iterable=chrome.use_chunked_encoding)
  File "/srv/trac-hacks.org/pve/lib/python2.7/site-packages/trac/web/chrome.py", line 1074, in render_template
    stream = template.generate(**data)
  File "/srv/trac-hacks.org/pve/lib/python2.7/site-packages/genshi/template/base.py", line 532, in generate
    stream = self.stream
  File "/srv/trac-hacks.org/pve/lib/python2.7/site-packages/genshi/template/base.py", line 442, in stream
    self._stream = list(self._prepare(self._stream))
  File "/srv/trac-hacks.org/pve/lib/python2.7/site-packages/genshi/template/base.py", line 478, in _prepare
    yield kind, (directives, list(substream)), pos
  File "/srv/trac-hacks.org/pve/lib/python2.7/site-packages/genshi/template/base.py", line 493, in _prepare
    for event in tmpl.stream:
  File "/srv/trac-hacks.org/pve/lib/python2.7/site-packages/genshi/template/base.py", line 442, in stream
    self._stream = list(self._prepare(self._stream))
  File "/srv/trac-hacks.org/pve/lib/python2.7/site-packages/genshi/template/markup.py", line 288, in _prepare
    self._extract_includes(self._interpolate_attrs(stream))
  File "/srv/trac-hacks.org/pve/lib/python2.7/site-packages/genshi/template/markup.py", line 210, in _extract_includes
    for kind, data, pos in stream:
  File "/srv/trac-hacks.org/pve/lib/python2.7/site-packages/genshi/template/markup.py", line 278, in _interpolate_attrs
    pos[2], lookup=self.lookup))
  File "/srv/trac-hacks.org/pve/lib/python2.7/site-packages/genshi/template/interpolation.py", line 69, in interpolate
    for is_expr, chunk in chain(lex(text, pos, filepath), [(True, '')]):
  File "/srv/trac-hacks.org/pve/lib/python2.7/site-packages/genshi/template/interpolation.py", line 106, in lex
    offset = text.find(PREFIX, pos)
AttributeError: 'list' object has no attribute 'find'

Attachments (0)

Change History (5)

comment:1 by Ryan J Ollos, 5 years ago

Component: generalquery system

comment:2 by Ryan J Ollos, 5 years ago

Owner: set to Ryan J Ollos
Status: newassigned

comment:3 by Ryan J Ollos, 4 years ago

Milestone: 1.0.111.0.12
Version: 1.0.10

I guess the issue must have been seen with Trac 1.0.10 because it was released on 2016-02-20, and I'm pretty sure I upgraded trac-hacks.org immediately. However, I can't reproduce by navigating to /query?status=closed&component=DoxygenPlugin&type=enhancement&group=resolution&max=0&desc=1&order=id.

in reply to:  description comment:4 by Ryan J Ollos, 4 years ago

Replying to Ryan J Ollos:

From the logs:

016-02-22 07:45:57,348 Trac[main] ERROR: Internal Server Error: <RequestWithSession "GET '/query?status=closed&amp;component=DoxygenPlugin&amp;type=enhancement&amp;group=resolution&amp;max=0&amp;desc=1&amp;order=id'">, referrer None

I don't see any html-entity presentation of & elsewhere in Trac bug reports, so I guess the path was as presented: /query?status=closed&amp;component=DoxygenPlugin&amp;type=enhancement&amp;group=resolution&amp;max=0&amp;desc=1&amp;order=id.

comment:5 by Ryan J Ollos, 4 years ago

Milestone: 1.0.12
Resolution: worksforme
Status: assignedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Ryan J Ollos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.