Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12283 closed defect (fixed)

Trac installed as a wheel does not appear as a single package on Plugin Admin page

Reported by: Ryan J Ollos Owned by: Jun Omae
Priority: normal Milestone: 1.0.10
Component: general Version:
Severity: normal Keywords: wheel
Cc: Branch:
Release Notes:

Fixed broken display of wheel packages on Plugins admin page and Installed Plugins table on About Trac page.

API Changes:

Add support of PEP 376 metadata to get_sources() in trac.util.

Internal Changes:

Description (last modified by Ryan J Ollos)

Here is what I see when Trac is installed as a wheel:

Workaround: the modules appear as a single package when the --no-use-wheel (deprecated) or --no-binary :all: option is used.

Attachments (1)

Screen Shot 2015-12-17 at 16.56.45.png (89.1 KB ) - added by Ryan J Ollos 5 years ago.

Download all attachments as: .zip

Change History (9)

by Ryan J Ollos, 5 years ago

comment:1 by Ryan J Ollos, 5 years ago

Description: modified (diff)

comment:2 by Ryan J Ollos, 5 years ago

SpamFilter has the same issue when installed as a wheel.

comment:3 by Ryan J Ollos, 5 years ago

Also reported in comment:15:ticket:12199.

comment:4 by Ryan J Ollos, 5 years ago

Description: modified (diff)

comment:5 by Jun Omae, 5 years ago

Owner: set to Jun Omae
Status: newassigned

This issue is caused by that get_sources() in trac.util doesn't support *.dist-info metadata.

Proposed changes in log:jomae.git@t12283.

comment:6 by Ryan J Ollos, 5 years ago

Changes work well for me.

comment:7 by Jun Omae, 5 years ago

Milestone: next-stable-1.0.x1.0.10
Release Notes: modified (diff)
Resolution: fixed
Status: assignedclosed

Thanks for the review. Committed in [14527] and merged to trunk in [14528].

comment:8 by Ryan J Ollos, 5 years ago

API Changes: modified (diff)
Release Notes: modified (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jun Omae to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.