Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12199 closed task (fixed)

Release Trac 1.0.10

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: normal Milestone: 1.0.10
Component: general Version:
Severity: normal Keywords: release
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

This ticket is used to coordinate the finalization and testing of the next stable version of Trac, 1.0.10.

Attachments (1)

Screen Shot 2016-02-03 at 02.35.52.png (165.5 KB ) - added by Thijs Triemstra 5 years ago.

Download all attachments as: .zip

Change History (24)

comment:1 by figaro, 5 years ago

Type: enhancementtask

comment:2 by Ryan J Ollos, 5 years ago

I've re-scheduled the milestone:1.0.10 release for 01 Jan 2016.

comment:3 by Ryan J Ollos, 5 years ago

It looks like this message hasn't been updated to include MySQL support: tags/trac-1.0.9/trac/admin/console.py@:391-395#L376.

in reply to:  3 comment:4 by Ryan J Ollos, 5 years ago

Replying to Ryan J Ollos:

It looks like this message hasn't been updated to include MySQL support: tags/trac-1.0.9/trac/admin/console.py@:391-395#L376.

Fixed on 1.0-stable in [14457], merged to trunk in [14458].

comment:5 by Ryan J Ollos, 5 years ago

I was considering adding a Ticket Component for Subversion now that it lives in tracopt. We have:

  • plugin/git
  • plugin/mercurial
  • plugin/spamfilter

Should we add plugin/svn? It's not really a plugin though, maybe we should rename plugin/git to versioncontrol/git and add versioncontrol/svn?

comment:6 by Ryan J Ollos, 5 years ago

According to comments below SO:650181/121030 it might be necessary to enable mod_version when using the <IfVersion> directive (Apache 2.2, Apache 2.4). As far as I can tell this isn't the case with Apache 2.2 or 2.4 on Debian, but I need to do more testing to be sure. If there are cases in which mod_version needs to be explicitly enabled, we might want to add a note about that to TracModPython@172, TracModWSGI@76 and TracInstall@426.

in reply to:  6 comment:7 by Jun Omae, 5 years ago

Replying to Ryan J Ollos:

According to comments below SO:650181/121030 it might be necessary to enable mod_version when using the <IfVersion> directive (Apache 2.2, Apache 2.4). As far as I can tell this isn't the case with Apache 2.2 or 2.4 on Debian, but I need to do more testing to be sure. If there are cases in which mod_version needs to be explicitly enabled, we might want to add a note about that to TracModPython@172, TracModWSGI@76 and TracInstall@426.

Oh…. That's so bad. I'll revert those changes. Thanks for the information.

comment:8 by Ryan J Ollos, 5 years ago

I created milestone:1.0.11 and will plan to create the 1.0.10 release on the weekend of Feb 13th-14th, if that works for everyone.

I haven't had any luck getting the Transifex charts to display in the milestone description. The markup on the widget page shows project-relative URLs. After prefixing with https://transifex.com the charts still don't display:

Top translations: trac » 1_0-stable-messages-pot

The URL https://www.transifex.com/projects/p/trac/resource/1_0-stable-messages-pot/chart/image_png redirects to:

https://chart.googleapis.com/chart?chxt=y%2Cr&chd=e%3A..........-E9b9b8y6O5l484848&chco=78dc7d%2Cdae1ee%2Cefefef&chbh=9&chs=350x196&cht=bhs&chxl=0%3A%7CHungarian%7CPortuguese+%28Brazil%29%7CHebrew%7CItalian%7CPolish%7CSpanish+%28Mexico%29%7CRussian%7CFrench%7CGerman%7CKorean%7CJapanese%7CEnglish%7CSwedish%7CEnglish+%28United+Kingdom%29%7C1%3A%7C89%25%7C89%25%7C89%25%7C90%25%7C91%25%7C95%25%7C96%25%7C96%25%7C97%25%7C100%25%7C100%25%7C100%25%7C100%25%7C100%25%7C

The chart will render when using that complex URL, but that doesn't seem a good way to fix the issue since the "top translations" are parameters in the URL.

Top translations: trac » 1_0-stable-messages-pot

in reply to:  8 ; comment:9 by Ryan J Ollos, 5 years ago

Replying to Ryan J Ollos:

The URL https://www.transifex.com/projects/p/trac/resource/1_0-stable-messages-pot/chart/image_png redirects to:

Would a possible fix be to make ImageMacro render the results from the redirected page?

in reply to:  9 comment:10 by Ryan J Ollos, 5 years ago

Replying to Ryan J Ollos:

Replying to Ryan J Ollos:

The URL https://www.transifex.com/projects/p/trac/resource/1_0-stable-messages-pot/chart/image_png redirects to:

Would a possible fix be to make ImageMacro render the results from the redirected page?

My error. I wasn't seeing the chart due to my ad blocker. Doh!

comment:11 by Christian Boos, 5 years ago

Yeah, sorry for not pointing out that I was seeing it… Instead I thought I didn't fully understand what result you expected.

Btw, while we're clarifying things, what's the current procedure for getting the Transifex stuff back in Trac?

in reply to:  11 ; comment:12 by Ryan J Ollos, 5 years ago

Replying to Christian Boos:

Btw, while we're clarifying things, what's the current procedure for getting the Transifex stuff back in Trac?

The Transifex translations have not been copied/merged back to Trac in the time I've been creating the releases (1.0.2+). I suspect there are some people that aren't too pleased with that, but I haven't yet made time to explore your proposed solutions (gmessage:trac-dev:l5YuG7DysOE/55yoiIW1DVEJ).

I wonder if it'd be simplest to just move all translation activity to Transifex so that we can copy the files without worrying about merging them. There are very few translators committing directly to Trac these days.

in reply to:  12 comment:13 by Christian Boos, 5 years ago

Replying to Ryan J Ollos:

Replying to Christian Boos:

Btw, while we're clarifying things, what's the current procedure for getting the Transifex stuff back in Trac?

The Transifex translations have not been copied/merged back to Trac in the time I've been creating the releases (1.0.2+). I suspect there are some people that aren't too pleased with that, but I haven't yet made time to explore your proposed solutions (gmessage:trac-dev:l5YuG7DysOE/55yoiIW1DVEJ).

Ok, I just wanted to be sure. It's not your fault really, the "process" involved a lot of manual steps and was too tedious. I also still haven't found the time to implement my "ideal" solution, so for the time being, we could indeed simply pull them back. Jun should tell us what he prefers for the Japanese translation.

I wonder if it'd be simplest to just move all translation activity to Transifex so that we can copy the files without worrying about merging them. There are very few translators committing directly to Trac these days.

comment:14 by Jun Omae, 5 years ago

It seems that English (source language) *.pot files on Transifex are not automatically updated on each commit of our subversion repository since Apr 2015. See https://www.transifex.com/cboos/trac/language/en/.

by Thijs Triemstra, 5 years ago

comment:15 by Thijs Triemstra, 5 years ago

1.0.9 has been very stable but after I upgraded from Python 2.7.6 to 2.7.10 today I noticed a new bug and I wondered if this is noticed/fixed in 1.0.10. I know, I should give 1.0.10 a pre-release try but hey, attached the screenshot ([attachment:Screen Shot 2016-02-03 at 02.35.52.png] didn't work).

in reply to:  15 comment:16 by Jun Omae, 5 years ago

Replying to Thijs Triemstra:

1.0.9 has been very stable but after I upgraded from Python 2.7.6 to 2.7.10 today I noticed a new bug and I wondered if this is noticed/fixed in 1.0.10. I know, I should give 1.0.10 a pre-release try but hey, attached the screenshot ([attachment:Screen Shot 2016-02-03 at 02.35.52.png] didn't work).

Not a defect. It needs to use quotes or double brackets.

[attachment:"Screen Shot 2016-02-03 at 02.35.52.png"]
[[attachment:Screen Shot 2016-02-03 at 02.35.52.png]]

Screen Shot 2016-02-03 at 02.35.52.png Screen Shot 2016-02-03 at 02.35.52.png

comment:17 by Thijs Triemstra, 5 years ago

Sorry I meant the error in the screenshot, I see all Trac .pyc files listed in the plugin section.

comment:18 by Jun Omae, 5 years ago

I guess an installation issue and I cannot reproduce it. However, please create new ticket rather than comments in this ticket.

comment:19 by Ryan J Ollos, 5 years ago

The issue has been reported in #12283, and there is a workaround described in the ticket.

comment:20 by Ryan J Ollos, 5 years ago

There are 3 open tickets in milestone:1.0.10 not assigned to me. I'll move those forward on Sunday unless the owners indicate they'd like to complete the tickets. I'll start the release process sometime after 23:00 GMT on Sunday 02/14, so there is still time to complete any tickets that need to be in the release.

comment:21 by Ryan J Ollos, 5 years ago

Owner: set to Ryan J Ollos
Status: newassigned

comment:22 by Ryan J Ollos, 5 years ago

Resolution: fixed
Status: assignedclosed

in reply to:  14 comment:23 by Ryan J Ollos, 5 years ago

Replying to Jun Omae:

It seems that English (source language) *.pot files on Transifex are not automatically updated on each commit of our subversion repository since Apr 2015. See https://www.transifex.com/cboos/trac/language/en/.

I don't have permissions on Transifex to investigate the issue, but I did notice that the separate SpamFilter project is still updating the pot files on every commit. That's not too informative though because the maintainer might have fixed any issue since April that broke the update.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Ryan J Ollos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.