Edgewall Software
Modify

Opened 7 years ago

Closed 7 years ago

#12207 closed defect (duplicate)

ValueError: Invalid boundary in multipart form: ''

Reported by: vij2cob Owned by:
Priority: normal Milestone:
Component: attachment Version: 0.12.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a POST operation on /attachment/ticket/1638/, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'action': u'new', 'description': u'', 'id': u'1638', 'realm': u'ticket'}

User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0; Mozilla Firefox 38.2.0 - 10792--71

System Information

Trac 0.12.2
Docutils 0.9
Genshi 0.6
mod_wsgi 3.3 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
Pygments 1.5
pysqlite 2.6.0
Python 2.7.2 (default, Jun 12 2011, 15:08:59) [MSC v.1500 32 bit (Intel)]
setuptools 0.6c11
SQLite 3.6.21
Subversion 1.7.8 (r1419691)
jQuery 1.4.2

Enabled Plugins

FieldTooltip 0.3
navadd 0.1
tracsimpleticket 5.0dev
tracthemeengine 2.0.1

Python Traceback

Traceback (most recent call last):
  File "D:\bin\Python27\lib\site-packages\trac\web\main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "D:\bin\Python27\lib\site-packages\trac\web\main.py", line 193, in dispatch
    if handler.match_request(req):
  File "D:\bin\Python27\lib\site-packages\trac\attachment.py", line 408, in match_request
    req.args['realm'] = realm
  File "D:\bin\Python27\lib\site-packages\trac\web\api.py", line 216, in __getattr__
    value = self.callbacks[name](self)
  File "D:\bin\Python27\lib\site-packages\trac\web\api.py", line 199, in <lambda>
    'args': lambda req: arg_list_to_args(req.arg_list),
  File "D:\bin\Python27\lib\site-packages\trac\web\api.py", line 216, in __getattr__
    value = self.callbacks[name](self)
  File "D:\bin\Python27\lib\site-packages\trac\web\api.py", line 564, in _parse_arg_list
    fs = cgi.FieldStorage(fp, environ=self.environ, keep_blank_values=True)
  File "D:\bin\Python27\Lib\cgi.py", line 508, in __init__
    self.read_multi(environ, keep_blank_values, strict_parsing)
  File "D:\bin\Python27\Lib\cgi.py", line 637, in read_multi
    environ, keep_blank_values, strict_parsing)
  File "D:\bin\Python27\Lib\cgi.py", line 508, in __init__
    self.read_multi(environ, keep_blank_values, strict_parsing)
  File "D:\bin\Python27\Lib\cgi.py", line 622, in read_multi
    raise ValueError, 'Invalid boundary in multipart form: %r' % (ib,)
ValueError: Invalid boundary in multipart form: ''

Attachments (0)

Change History (1)

comment:1 by Jun Omae, 7 years ago

Component: generalattachment
Resolution: duplicate
Status: newclosed

A duplicate of #9880. Please upgrade to Trac 0.12.5 or later.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.