Edgewall Software
Modify

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#12174 closed defect (duplicate)

Property change in batch ticket notification is incorrect

Reported by: Ryan J Ollos Owned by:
Priority: normal Milestone:
Component: notification Version: 1.1dev
Severity: normal Keywords: batch-modify
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

When a user is batch removed from the CC list, the notification email displays the following:

Batch modification to #29 by user1:
cc to ryan.j.ollos@...

The same message is displayed when a user is batch added. I haven't checked if the issue occurs on 1.0-stable.

Attachments (0)

Change History (8)

comment:1 by Ryan J Ollos, 6 years ago

Owner: set to Ryan J Ollos
Status: newassigned

comment:2 by Ryan J Ollos, 6 years ago

new_values contains the value passed in the input field and there is no information passed about whether the value is added or removed: tags/trac-1.1.6/trac/ticket/notification.py@:957-958#L923.

We could create a list of added and removed values in _change_list and pass it to BatchTicketChangeEvent in place of new_values: tags/trac-1.1.6/trac/ticket/batch.py@:181-182#L162.

Last edited 6 years ago by Ryan J Ollos (previous) (diff)

comment:3 by Ryan J Ollos, 6 years ago

Milestone: 1.2next-major-releases

comment:4 by Ryan J Ollos, 6 years ago

Keywords: bitesized added

comment:5 by Ryan J Ollos, 6 years ago

Owner: Ryan J Ollos removed
Status: assignednew

comment:6 by Jun Omae, 5 years ago

Milestone: next-major-releasesnext-stable-1.0.x

1.0-stable has the same issue. See comment:4:ticket:12585.

comment:7 by Jun Omae, 5 years ago

Keywords: bitesized removed
Resolution: duplicate
Status: newclosed

A duplicate of #11271.

comment:8 by Jun Omae, 5 years ago

Milestone: next-stable-1.0.x

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.