Edgewall Software
Modify

Opened 17 years ago

Closed 17 years ago

Last modified 15 years ago

#1214 closed defect (duplicate)

Error "global name 'True' is not defined"

Reported by: matt.faure@… Owned by: Jonas Borgström
Priority: normal Milestone:
Component: wiki system Version: 0.8
Severity: major Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

After publishing a page (without preview), I got the following error:

Trac detected an internal error:
global name 'True' is not defined

With the associated Python traceback:

Traceback (most recent call last):
  File "/usr/lib/python2.1/site-packages/trac/core.py", line 525, in cgi_start
    real_cgi_start()
  File "/usr/lib/python2.1/site-packages/trac/core.py", line 520, in real_cgi_start
    dispatch_request(path_info, args, req, env)
  File "/usr/lib/python2.1/site-packages/trac/core.py", line 435, in dispatch_request
    module.run()
  File "/usr/lib/python2.1/site-packages/trac/Module.py", line 44, in run
    self.render()
  File "/usr/lib/python2.1/site-packages/trac/Wiki.py", line 339, in render
    Formatter(self.req.hdf, self.env,self.db).format(self.page.text, out)
  File "/usr/lib/python2.1/site-packages/trac/WikiFormatter.py", line 569, in format
    result = re.sub(rules, self.replace, line)
  File "/usr/lib/python2.1/sre.py", line 63, in sub
    return _compile(pattern, 0).sub(repl, string, count)
  File "/usr/lib/python2.1/sre.py", line 164, in _sub
    return _subn(pattern, template, string, count)[0]
  File "/usr/lib/python2.1/sre.py", line 185, in _subn
    append(filter(m))
  File "/usr/lib/python2.1/site-packages/trac/WikiFormatter.py", line 68, in replace
    return getattr(self, '_' + itype + '_formatter')(match, fullmatch)
  File "/usr/lib/python2.1/site-packages/trac/WikiFormatter.py", line 381, in _indent_formatter
    self.in_list_item = True
NameError: global name 'True' is not defined

Thus, my page is unusable :-/

I checked ticket #1011 but I didn't use RST (I also applied the diff, but it was unsuccessfull).

I don't remember exactly what I typed, but perhaps it could be a problem with nested lists and/or titles.

Contextual informations: debian stable, python 2.1.3

Attachments (0)

Change History (1)

comment:1 by Christopher Lenz, 17 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #1003.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.