Edgewall Software
Modify

Opened 17 years ago

Closed 17 years ago

#1211 closed enhancement (fixed)

Want to allow authenticated users to attach files but not modify tickets.

Reported by: tangstad@… Owned by: Jonas Borgström
Priority: normal Milestone: 0.9
Component: ticket system Version: 0.8
Severity: normal Keywords:
Cc: tangstad@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

For specific customers/bugreporters we really need a way to attach datafiles that help us reproduce their bugs, but without giving them full TICKET_MODIFY access. The TICKET_MODIFY access would just be confusing with too many options, and at the same time they might modify resolution etc. which would be annoying for developers.

It would be very practical to have a TICKET_APPEND permission which would let certain users (or anonymous) be able to attach files and add comments to an existing ticket.

Attachments (0)

Change History (2)

comment:1 by Christopher Lenz, 17 years ago

#1436 has been marked as duplicate of this ticket. Also, #1396 has a patch that addresses this.

comment:2 by Christopher Lenz, 17 years ago

Milestone: 0.9
Resolution: fixed
Status: newclosed

Implemented in [1516].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.