Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11969 closed task (fixed)

Specify minimum supported version of PySqlite

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: normal Milestone: 1.1.4
Component: database backend Version:
Severity: normal Keywords: sqlite pysqlite
Cc: Branch:
Release Notes:

Minimum version of pysqlite is enforced to be 2.4.1. Minimum version of SQLite is enforced to be 3.0.0.

API Changes:

Description (last modified by Ryan J Ollos)

Python 2.5 include sqlite3. The proposed change is that we adopt as the minimum supported version of PySqlite the version of PySqlite provided in the sqlite3 module by the minimum supported version of Python. For Python 2.6 this will be PySqlite 2.4.1.

Attachments (0)

Change History (10)

comment:1 by Ryan J Ollos, 5 years ago

I was confused by the code, SQLite 2.x is already not supported. However, we can clarify supported PySqlite versions.

Last edited 5 years ago by Ryan J Ollos (previous) (diff)

comment:2 by Ryan J Ollos, 5 years ago

Description: modified (diff)
Milestone: undecided1.1.5
Owner: set to Ryan J Ollos
Status: newassigned
Summary: Remove support for SQLite < 3.0Specify minimum supported version of PySqlite

comment:3 by Ryan J Ollos, 5 years ago

With sqlite3 included in the standard library in Python 2.5 and later I can't foresee a scenario in which the PySqlite bindings aren't available in a valid Python installation. That motivated some cleanup of the code and elimination of the have_sqlite check. Proposed changes in log:rjollos.git:t11969.

Last edited 5 years ago by Ryan J Ollos (previous) (diff)

comment:4 by Jun Omae, 5 years ago

Looks good to me. Confirmed on both Python 2.6 with bundled pysqlite 2.4.1 (sqlite3 is used) and Python 2.6 with new installed pysqlite 2.6.3 (pysqlite2.dbapi2 is used).

comment:5 by Ryan J Ollos, 5 years ago

Milestone: 1.1.51.1.4
Release Notes: modified (diff)
Resolution: fixed
Status: assignedclosed

Thanks for the review. Committed in [13805].

comment:6 by Ryan J Ollos, 5 years ago

Keywords: pysqlite added

comment:7 by Ryan J Ollos, 5 years ago

We could also enforce the SQLite version in the module: log:rjollos.git:t11969.1

comment:8 by Jun Omae, 5 years ago

I don't understand we should enforce SQLite >= 3.0.8. Do you have an experience with incompatibilities and issues on 3.0.7 or early? If there is any issues with 3.0.7 or early, I think pysqlite should check it.

If any issues with 3.0.7 or early on Trac, it would be good to add the check to Trac.

comment:9 by Ryan J Ollos, 5 years ago

I'll set requirement to 3.0.0 if you'd prefer. My main motivation is to set the stage for Trac 1.3.1 when we drop compatibility with all these old versions of dependencies.

comment:10 by Ryan J Ollos, 5 years ago

Release Notes: modified (diff)

Committed to trunk in [13861].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Ryan J Ollos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.