Edgewall Software
Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#11829 closed defect (worksforme)

Scrolling closes the "Modify Ticket" area

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: general Version: 1.0.1
Severity: normal Keywords: scrolling
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

Open a tiket in a new tab or refresh the page. Enter some text in the "Add Comment" box and scroll down either via the scroll wheel or the scroll bar on the right and the "Modify Ticket" area closes.

Open the ticket and scroll up/down all you want and it doesn't close the "Modify Ticket" area but once you enter the text, the next scrolling will close it. This is reproducible every time.

Running FF 33 under Fedora 20 with Mate desktop.

Attachments (0)

Change History (3)

comment:1 by anonymous, 8 years ago

Just noticed that it's not scrolling that causes the error as after entering text, the first thing I did was to scroll.

Turns out that if you enter text into the "Add Comment" box and wait 2-3 seconds, the "Modify Ticket" area closes. You can type all you want, but once you stop typing, the "Modify Ticket" area closes.

Really disruptive to the workflow.

comment:2 by Christian Boos, 8 years ago

Resolution: worksforme
Status: newclosed

This was done on purpose so that you could immediately see the ticket comment preview.

However we also found that to be non-optimal, so this has changed in more recent versions: as you can see here (Trac 1.1.3), the ticket modification form stays opened as it's now above the comment editor, so it doesn't prevent you to see the comment preview right below the editor.

That behavior is not going to change on 1.0.x and is no longer there on 1.1.x.

comment:3 by Ryan J Ollos, 8 years ago

The ticket in which the behavior was changed for 1.1.3 is #10207.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.