Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11800 closed defect (invalid)

TemplateNotFound: Template "report_list.html" not found

Reported by: davidbonnin@… Owned by:
Priority: high Milestone:
Component: general Version: 1.1.2
Severity: blocker Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

since update from 1.1.1 to 1.1.2, i can't acces to roadmap and view ticket. the only special thing i've done, is change required setuptools version from 0.6 to 0.5, because doesn't want install with my version 0.6c9

thanks to any help.

How to Reproduce

While doing a GET operation on /report, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{}

User agent: Mozilla/5.0 (Windows NT 6.1; rv:33.0) Gecko/20100101 Firefox/33.0

System Information

Trac 1.1.2.my2
Babel 0.9.5
Docutils 0.5
Genshi 0.6 (without speedups)
mod_python 3.3.1
Pygments 1.0
pysqlite 2.4.1
Python 2.6.4 (r264:75706, Dec 7 2009, 19:02:09)
[GCC 4.4.1]
pytz 2009l
setuptools 0.6c9
SQLite 3.6.16
Subversion 1.6.5 (r38866)
jQuery 1.8.3
jQuery UI 1.9.2
jQuery Timepicker 1.1.1

Enabled Plugins

TracAccountManager 0.4dev

Python Traceback

Traceback (most recent call last):
  File "build/bdist.linux-i686/egg/trac/web/main.py", line 550, in _dispatch_request
    dispatcher.dispatch(req)
  File "build/bdist.linux-i686/egg/trac/web/main.py", line 244, in dispatch
    method=method)
  File "build/bdist.linux-i686/egg/trac/web/chrome.py", line 1026, in render_template
    template = self.load_template(filename, method=method)
  File "build/bdist.linux-i686/egg/trac/web/chrome.py", line 989, in load_template
    return self.templates.load(filename, cls=cls)
  File "build/bdist.macosx-10.6-universal/egg/genshi/template/loader.py", line 246, in load
    raise TemplateNotFound(filename, search_path)
TemplateNotFound: Template "report_list.html" not found

Attachments (0)

Change History (5)

in reply to:  description comment:1 by Ryan J Ollos, 5 years ago

Replying to davidbonnin@…:

since update from 1.1.1 to 1.1.2, i can't acces to roadmap and view ticket. the only special thing i've done, is change required setuptools version from 0.6 to 0.5, because doesn't want install with my version 0.6c9

I suggest updating setuptools in your installation. You can imagine that we enforce required versions because earlier versions are not supported and maybe don't work at all, so if you are trying to run with an unsupported dependency we will not support that.

You are on Windows platform so I don't see why it would be a problem to upgrade your setuptools package.

comment:2 by anonymous, 5 years ago

I'm on linux, ubuntu karmic 9.10, not windows(just the user browser)

I've succes to upgrade to setuptools to 0.7, but i still have the problem.

What other information can i give you to help?

in reply to:  2 comment:3 by Jun Omae, 5 years ago

I've succes to upgrade to setuptools to 0.7, but i still have the problem.

After setuptools upgrading, it need to reinstall Trac. Have you reinstalled?

Source archive has report_list.html file and the file is installed.

$ virtualenv /dev/shm/t11800
...
$ wget -P /tmp/ http://download.edgewall.org/trac/Trac-1.0.2.tar.gz
...
$ tar tzvf /tmp/Trac-1.0.2.tar.gz | grep report_list.html
-rw-rw-r-- user/user      5347 2014-10-24 12:19 Trac-1.0.2/trac/ticket/templates/report_list.html
$ /dev/shm/t11800/bin/easy_install -ZU Genshi==0.6
...
$ /dev/shm/t11800/bin/easy_install -ZU /tmp/Trac-1.0.2.tar.gz
...
$ ls -l /dev/shm/t11800/lib/python2.7/site-packages/Trac-1.0.2-py2.7.egg/trac/ticket/templates/report_list.html
-rw-r--r-- 1 jun66j5 jun66j5 5347 Oct 31 19:52 /dev/shm/t11800/lib/python2.7/site-packages/Trac-1.0.2-py2.7.egg/trac/ticket/templates/report_list.html
Last edited 5 years ago by Jun Omae (previous) (diff)

comment:4 by davidbonnin@…, 5 years ago

Resolution: invalid
Status: newclosed

ok, it's solved, soory, i made identation error in trac/ticket/web_ui.py.

I'm surprised to see that build didn't stop….

I made a modification to have a special ticket field: it is a text field ( like: "379" ), and then it display inside an URL, like: http://quality.intranet/tracking/issue/379.

(off topic: i try now to create a second milestone field (ask in pass in #irc)).

in reply to:  4 comment:5 by Ryan J Ollos, 5 years ago

Replying to davidbonnin@…:

(off topic: i try now to create a second milestone field (ask in pass in #irc)).

Depending on your requirements a custom field might be appropriate. If you didn't get a reply on IRC please consider asking on the MailingList.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.