Edgewall Software
Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11794 closed enhancement (fixed)

Rename 'Comments only' label in #prefs on the ticket page

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: normal Milestone: 1.1.3
Component: ticket system Version:
Severity: normal Keywords:
Cc:
Release Notes:

The ticket prefs checkbox label was changed from Comments only to Show property changes.

API Changes:

On the ticket prefs form the id of the Show property changes (formerly Comments only) checkbox was renamed from trac-comments-only-toggle to trac-show-property-changes-toggle.

Description

As proposed in comment:13:ticket:10766, rename the checkbox label in the #prefs on the ticket page from Comments only to Hide property changes.

Attachments (0)

Change History (9)

comment:1 Changed 4 years ago by Ryan J Ollos

Status: newassigned

I'll apply the following diff in a few days if there are no comments on the change.

  • trac/ticket/templates/ticket.html

    diff --git a/trac/ticket/templates/ticket.html b/trac/ticket/templates/ticket.html
    index 353ef63..ae2d87c 100644
    a b  
    163163              </div>
    164164              <div>
    165165                <input id="trac-comments-only-toggle" type="checkbox" />
    166                 <label for="trac-comments-only-toggle">Comments only</label>
     166                <label for="trac-comments-only-toggle">Hide property changes</label>
    167167              </div>
    168168            </form>
    169169          </div>

comment:2 Changed 4 years ago by Peter Suter

Yes, sounds slightly better to me, too.

(Maybe even better would be Show property changes with inverted logic?)

comment:3 in reply to:  2 ; Changed 4 years ago by Ryan J Ollos

Replying to psuter:

(Maybe even better would be Show property changes with inverted logic?)

I've given it some consideration. Two things come to mind:

  • Changing from Comments only to Show property changes without an upgrade step would invert the user's saved session preference. This is hardly an issue since the user would just need to save their preference again.
  • Hide property changes would default to false. The initial behavior of showing everything might be more expected and predictable for new users of Trac as well as users coming from older versions of Trac.

Overall though I don't find a particularly strong argument for one over the other: Hide property changes vs Show property changes.

comment:4 in reply to:  3 ; Changed 4 years ago by Peter Suter

Replying to rjollos:

  • Changing from Comments only to Show property changes without an upgrade step would invert the user's saved session preference. This is hardly an issue since the user would just need to save their preference again.
  • Hide property changes would default to false. The initial behavior of showing everything might be more expected and predictable for new users of Trac as well as users coming from older versions of Trac.

I agree that both points would be undesirable. I thought we could avoid them, e.g. by keeping the comments_only flag internally as is, and only negating the checkbox logic somehow. But maybe it's not as simple and gets too ugly in practice.

My main argument for Show is that it avoids a kind of double negative for new users: It can be slightly confusing that show (positive) means uncheck hide (double negative). But it's not that important, so if the changes aren't simple it's probably not worth it.

comment:5 in reply to:  4 Changed 4 years ago by Ryan J Ollos

Replying to psuter:

I agree that both points would be undesirable. I thought we could avoid them, e.g. by keeping the comments_only flag internally as is, and only negating the checkbox logic somehow. But maybe it's not as simple and gets too ugly in practice.

My main argument for Show is that it avoids a kind of double negative for new users: It can be slightly confusing that show (positive) means uncheck hide (double negative). But it's not that important, so if the changes aren't simple it's probably not worth it.

That seems like a good approach. I can't see a way to accomplish the change while leaving the code readable without a change to an id. Other than that, there doesn't seem to be any downside to the changes: log:rjollos.git:t11794.1.

comment:6 Changed 4 years ago by Ryan J Ollos

API Changes: modified (diff)
Release Notes: modified (diff)

comment:7 Changed 4 years ago by Ryan J Ollos

If the CSS in [a4c13e76/rjollos.git] is deemed generally useful we could add a trac-unselectable-text class.

Last edited 4 years ago by Ryan J Ollos (previous) (diff)

comment:8 Changed 4 years ago by Ryan J Ollos

Resolution: fixed
Status: assignedclosed

Committed to trunk in [13220]. Pot file refreshed in [13222].

comment:9 Changed 4 years ago by Ryan J Ollos

While working on #11612, I noticed that the autopreview logic was inverted in [13220]. The issue is fixed in [13247].

Last edited 4 years ago by Ryan J Ollos (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted.
to The owner will be changed from Ryan J Ollos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.