Edgewall Software
Modify

Opened 17 years ago

Closed 17 years ago

#1170 closed defect (duplicate)

changing components after deleting unused components results in python exception

Reported by: Markus Bertheau <twanger@…> Owned by: Jonas Borgström
Priority: normal Milestone:
Component: ticket system Version: 0.8
Severity: normal Keywords:
Cc: Markus Bertheau <twanger@…> Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Christopher Lenz)

I installed trac, created a few tickets with the default component component1, used trac-admin to create a component "alles" and remove component1 and component2, went to a ticket and wanted to change the component from component1 to alles, but got the following exception:

Traceback (most recent call last):

File "/usr/lib/python2.3/site-packages/trac/core.py", line 525, in cgi_start

real_cgi_start()

File "/usr/lib/python2.3/site-packages/trac/core.py", line 520, in real_cgi_start

dispatch_request(path_info, args, req, env)

File "/usr/lib/python2.3/site-packages/trac/core.py", line 435, in dispatch_request

module.run()

File "/usr/lib/python2.3/site-packages/trac/Module.py", line 44, in run

self.render()

File "/usr/lib/python2.3/site-packages/trac/Ticket.py", line 444, in render

self.save_changes (id)

File "/usr/lib/python2.3/site-packages/trac/Ticket.py", line 372, in save_changes

when=now)

File "/usr/lib/python2.3/site-packages/trac/Ticket.py", line 139, in save_changes

old_owner = cursor.fetchone()[0]

TypeError: unsubscriptable object

Attachments (0)

Change History (1)

comment:1 by Christopher Lenz, 17 years ago

Description: modified (diff)
Resolution: duplicate
Status: newclosed

This is a duplicate of #1045, which has been fixed.

Please search for existing tickets before submitting a new one.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.