Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

#11662 closed defect (fixed)

No permission check on repository that raises a TracError

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: normal Milestone: 1.0.2
Component: version control/browser Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:

Fixed permission check on repository that raises an exception or is not defined.

API Changes:

Description

To reproduce:

  • Create a repository with an invalid path.
  • Revoke BROWSER_VIEW for the user.

The Browse Source tab will be visible and the repository can be viewed from the repository index.

In [10006#file2] a permission check was added on 0.12-stable, but the length of the tuple was changed in [9976] for 1.0.

Attachments (0)

Change History (4)

comment:1 by Ryan J Ollos, 5 years ago

Owner: set to Ryan J Ollos
Status: newassigned

Proposed changes in log:rjollos.git:t11662. Additional refactoring for the trunk in log:rjollos.git:t11662_trunk.

comment:2 by Jun Omae, 5 years ago

Looks good to me. IMO, it would be good to apply the changes of [964570d4/rjollos.git] to 1.0-stable.

in reply to:  2 comment:3 by Ryan J Ollos, 5 years ago

Replying to jomae:

Looks good to me. IMO, it would be good to apply the changes of [964570d4/rjollos.git] to 1.0-stable.

I was less confident of the changes so I thought it would be safer to push to trunk, but since you've reviewed the changes I'll go ahead and push to 1.0-stable with greater confidence.

comment:4 by Ryan J Ollos, 5 years ago

Release Notes: modified (diff)
Resolution: fixed
Status: assignedclosed

Committed to 1.0-stable in [12885:12886], merged in [12887:12888].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Ryan J Ollos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.