Edgewall Software
Modify

Opened 8 years ago

Closed 6 years ago

#11643 closed enhancement (duplicate)

Create Version when closing a milestone

Reported by: Ryan J Ollos Owned by:
Priority: normal Milestone:
Component: ticket system Version:
Severity: normal Keywords: milestone version
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

It was discussed on the mailing list (gdiscussion:trac-users:H3FL08nV0Ow), that it would be convenient to create a Version when closing a milestone.

On the ticket edit form, when the Completed checkbox has been selected and the user has TICKET_ADMIN, a checkbox could be displayed below the Retarget checkbox with an input for the Version name. By default, the Version name could be the same as the milestone name. Here is the example markup for milestone Release 1.0.2:




The Released date of the Version would be the same as the Completed date of the milestone. Version-milestone relations were also discussed on the mailing list (see also #7802), but that feature is outside the scope of this ticket. That feature might be considered as an extension of #1233, in which Versions and Components will be made first-class objects in the Trac system.

Attachments (0)

Change History (5)

comment:1 by Robbie <robertvehse@…>, 8 years ago

Is there a way to subscribe to a ticket other than commenting on it?

comment:2 by Ryan J Ollos, 8 years ago

Commenting on a ticket doesn't actually subscribe you to it. You can subscribe by entering your name and email in prefs and then checking the Add/Remove from Cc: box in the ticket form.

in reply to:  description ; comment:3 by Peter Suter, 8 years ago

it would be convenient to create a Version when closing a milestone.

Note that the MilestoneToVersion sample plugin already provides this feature except the checkbox. (Created after discussion and rejection of such a feature in Trac core. See #6543.)

Last edited 8 years ago by Peter Suter (previous) (diff)

in reply to:  3 comment:4 by Ryan J Ollos, 8 years ago

Replying to psuter:

Note that the MilestoneToVersion sample plugin already provides this feature except the checkbox. (Created after discussion and rejection of such a feature in Trac core. See #6543.)

Thanks for the references. The feature might be suitable for moving into tracopt.

comment:5 by Ryan J Ollos, 6 years ago

Milestone: undecided
Resolution: duplicate
Status: newclosed

Closing as a duplicate of #6543. The milestone_to_version.py plugin works well.

If the request comes up more frequently, we might consider moving the plugin to tracopt.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.