Edgewall Software
Modify

Opened 5 years ago

Closed 5 years ago

#11607 closed defect (fixed)

font is not valid in newer firefox versions

Reported by: wuker@… Owned by: Jun Omae
Priority: normal Milestone: 0.12.6
Component: rendering Version: 1.0-stable
Severity: normal Keywords: firefox css
Cc: Jun Omae
Release Notes:

Avoid respect to system font settings for controls on Firefox.

API Changes:

Description

in

htdocs/common/css/trac.css

there is a section

/* Forms */
input, textarea, select { margin: 2px }

which is missing a ; and there should be added a font-size definition, otherwise the font has the system-default fontsize, which can be really huge at a retina display (Hi-Resolution displays)

so It should look like

/* Forms */
input, textarea, select {
 margin: 2px;
 font-size:13px;
}

Attachments (1)

Auswahl_0011998x1573_2014050108:53:21.png (170.8 KB ) - added by wuker@… 5 years ago.
Screenshot on a high resolution display

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by wuker@…

Screenshot on a high resolution display

comment:1 in reply to:  description Changed 5 years ago by Jun Omae

Component: generalrendering
Keywords: firefox added
Milestone: undecided
Version: 1.0-stable
/* Forms */
input, textarea, select { margin: 2px }

which is missing a ;

No. That is valid.

… and there should be added a font-size definition, otherwise the font has the system-default fontsize, which can be really huge at a retina display (Hi-Resolution displays)

Are you using which version of Firefox and Operating system?

Firefox respects font-family in system font settings for form widgets all along. However, I don't know whether font-size is respected or not.

refs http://mxr.mozilla.org/mozilla-central/source/layout/style/forms.css.

comment:2 Changed 5 years ago by anonymous

I use Linux Ubuntu 14.04 with a global zoom factor of 2.0.

If i reset the zoom factor to default 1.0 everything looks fine, but only because then everything is really small.

If I set it to 2.0 only the input fields get resized by factor 2.0 but all other text in Trac isn't.

My suggested solution with font-size:13px; definitely defined fixes this issue for zoom factor 2 and has no negative effect on a normal zoom.

It seems like font: 13px Helvetia,... isn't supported anymore since Firefox 24 or so

comment:3 Changed 5 years ago by Jun Omae

Cc: Jun Omae added

Thanks for feedback.

It would be good to apply the following. I don't think that font-size is needed for textarea because its initial value is medium on Firefox.

  • trac/htdocs/css/trac.css

     
    6868
    6969/* Forms */
    7070input, textarea, select { margin: 2px }
     71input, select, button { font-family: inherit; font-size: 100% }
    7172/* Avoid to inherit white-space of its parent element for IE 11, #11376 */
    7273textarea { white-space: pre-wrap }
    7374input, select { vertical-align: middle }

comment:4 Changed 5 years ago by anonymous

yes confirmed, you are right: font-size:100% seems to work fine as well, and textareas are not affected.

comment:5 Changed 5 years ago by Jun Omae

Keywords: css added
Milestone: undecided0.12.6
Owner: set to Jun Omae
Status: newassigned

Thanks. I also confirmed on fresh install of Ubuntu 14.04. Firefox on Windows 7 doesn't have the issue.

I'll apply the changes to 0.12-stable, 1.0-stable and trunk later.

comment:6 Changed 5 years ago by Jun Omae

Release Notes: modified (diff)
Resolution: fixed
Status: assignedclosed

Fixed in [12769] and merged to [12770] and [12772].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted.
to The owner will be changed from Jun Omae to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.