Edgewall Software
Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#11570 closed defect (invalid)

ValueError: need more than 1 value to unpack

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: general Version: 0.12.2
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on , Trac issued an internal error.

(please provide additional details here)

Request parameters:

{}

User agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 202, in dispatch
    chosen_handler)
  File "/usr/lib/python2.7/dist-packages/trac/web/main.py", line 344, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "/usr/lib/python2.7/dist-packages/trac/versioncontrol/api.py", line 330, in pre_process_request
    repo = self.get_repository(reponame)
  File "/usr/lib/python2.7/dist-packages/trac/versioncontrol/api.py", line 503, in get_repository
    repoinfo = self.get_all_repositories().get(reponame, {})
  File "/usr/lib/python2.7/dist-packages/trac/versioncontrol/api.py", line 571, in get_all_repositories
    for reponame, info in provider.get_repositories() or []:
  File "/usr/lib/python2.7/dist-packages/trac/versioncontrol/api.py", line 112, in get_repositories
    db = self.env.get_db_cnx()
  File "/usr/lib/python2.7/dist-packages/trac/env.py", line 328, in get_db_cnx
    return get_read_db(self)
  File "/usr/lib/python2.7/dist-packages/trac/db/api.py", line 90, in get_read_db
    return _transaction_local.db or DatabaseManager(env).get_connection()
  File "/usr/lib/python2.7/dist-packages/trac/db/api.py", line 150, in get_connection
    connector, args = self.get_connector()
  File "/usr/lib/python2.7/dist-packages/trac/db/api.py", line 183, in get_connector
    scheme, args = _parse_db_str(self.connection_uri)
  File "/usr/lib/python2.7/dist-packages/trac/db/api.py", line 219, in _parse_db_str
    scheme, rest = db_str.split(':', 1)
ValueError: need more than 1 value to unpack

Attachments (0)

Change History (1)

comment:1 by Ryan J Ollos, 9 years ago

Resolution: invalid
Status: newclosed

InstallationIssue: Your [trac] database string is incorrect. Duplicate of #2892, #5147, #8562, #11189, #11243. The error message for such occurrences has been improved in #11189, for release in Trac 1.0.2.

See TracEnvironment#DatabaseConnectionStrings and ask on the MailingList if you continue to have trouble.

Last edited 9 years ago by Ryan J Ollos (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.