Edgewall Software
Modify

Opened 9 years ago

Closed 9 years ago

#11243 closed defect (duplicate)

ValueError: need more than 1 value to unpack

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: general Version: 1.0.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{}

User agent: #USER_AGENT#

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback #most recent call last#:
  File "c:\python25\lib\site-packages\Trac-1#0#1-py2#5-win32#egg\trac\web\main#py", line 497, in _dispatch_request
    dispatcher#dispatch#req#
  File "c:\python25\lib\site-packages\Trac-1#0#1-py2#5-win32#egg\trac\web\main#py", line 179, in dispatch
    chosen_handler#
  File "c:\python25\lib\site-packages\Trac-1#0#1-py2#5-win32#egg\trac\web\main#py", line 325, in _pre_process_request
    chosen_handler = filter_#pre_process_request#req, chosen_handler#
  File "c:\python25\lib\site-packages\Trac-1#0#1-py2#5-win32#egg\trac\versioncontrol\api#py", line 343, in pre_process_request
    repo = self#get_repository#repona#e#
  File "c:\python25\lib\site-packages\Trac-1#0#1-py2#5-win32#egg\trac\versioncontrol\api#py", line 530, in get_repository
    repoinfo = self#get_all_repositories###get#repona#e, {}#
  File "c:\python25\lib\site-packages\Trac-1#0#1-py2#5-win32#egg\trac\versioncontrol\api#py", line 596, in get_all_repositories
    for repona#e, info in provider#get_repositories## or ##:
  File "c:\python25\lib\site-packages\Trac-1#0#1-py2#5-win32#egg\trac\versioncontrol\api#py", line 124, in get_repositories
    % ","#join#"'%s'" % each for each in self#repository_attrs#):
  File "c:\python25\lib\site-packages\Trac-1#0#1-py2#5-win32#egg\trac\db\api#py", line 121, in execute
    with self as db:
  File "c:\python25\lib\site-packages\Trac-1#0#1-py2#5-win32#egg\trac\db\api#py", line 174, in __enter__
    db = self#dbmgr#get_connection#readonly=True#
  File "c:\python25\lib\site-packages\Trac-1#0#1-py2#5-win32#egg\trac\db\api#py", line 260, in get_connection
    connector, args = self#get_connector##
  File "c:\python25\lib\site-packages\Trac-1#0#1-py2#5-win32#egg\trac\db\api#py", line 300, in get_connector
    scheme, args = _parse_db_str#self#connection_uri#
  File "c:\python25\lib\site-packages\Trac-1#0#1-py2#5-win32#egg\trac\db\api#py", line 339, in _parse_db_str
    scheme, rest = db_str.split#':', 1#
ValueError: need more than 1 value to unpack

Attachments (0)

Change History (1)

comment:1 by Remy Blank, 9 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #11189. Your database connection string is wrong.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.