Edgewall Software
Modify

Opened 6 years ago

Closed 3 years ago

#11199 closed defect (wontfix)

Auto preview ignores site.html customizations

Reported by: nacin@… Owned by:
Priority: normal Milestone:
Component: ticket system Version: 1.0.1
Severity: normal Keywords: verify
Cc: Ryan J Ollos, leho@… Branch:
Release Notes:
API Changes:

Description

We have a fairly complex site.html file which is used to customize different pieces of Trac. We recognize that things may break from release to release, and we test and migrate it with every release.

In site.html, we add gravatars to comments. The new auto preview code in 1.0 broke this, as it loads ticket_preview/ticket_box/ticket_change.html directly, without any opportunity for site.html to modify it.

If this is a wontfix/not a bug, that's fine. It was just very unexpected. We will modify our code to overload ticket_change.html directly.

Attachments (0)

Change History (6)

comment:1 by Ryan J Ollos, 5 years ago

Cc: Ryan J Ollos added
Keywords: verify added
Milestone: undecided

Are there any files you could provide to directly support testing the scenario?

comment:2 by lkraav <leho@…>, 4 years ago

Cc: leho@… added

comment:3 by Ryan J Ollos, 3 years ago

I assume you are referring to the Wordpress Trac, which is currently displaying Gravatars on the ticket page, even during autopreview. Is there a patch you'd like to propose?

comment:4 by Ryan J Ollos, 3 years ago

See also #12210.

comment:5 by Jun Omae, 3 years ago

I suggest wontfix. site.html cannot solve it. The site.html would be applied to only templates including layout.html.

Modifying the author fields could be solved by replacing authorinfo via post_process_request as a Trac plugin, or put customized ticket_box.html and ticket_change.html to your Trac Environment.

comment:6 by Ryan J Ollos, 3 years ago

Milestone: undecided
Resolution: wontfix
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.