Edgewall Software
Modify

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#11177 closed defect (worksforme)

Batch Modify ticket selection

Reported by: mokareem10@… Owned by:
Priority: low Milestone:
Component: query system Version: 1.0-stable
Severity: minor Keywords: needinfo
Cc: mokareem10@…, ryan.j.ollos@… Branch:
Release Notes:
API Changes:

Description

I searched for another ticket but could not find one.

The issue I've encountered is fairly minor but, nonetheless, a bug. When selecting tickets in the Custom Query for Batch Modification, there is a bug with the "Select All" checkbox.

If you click the column header checkbox, it selects all of the tickets in the list. If you then deselect each individual checkbox (for each ticket) they will all be deselected, but the header checkbox is still selected.

See the attached screenshot for additional details.

Select-all checkbox doesn't deselect

Attachments (3)

batch-modify-selection.png (3.5 KB ) - added by mokareem10@… 6 years ago.
Select-all checkbox doesn't deselect
TriStateChrome.png (5.3 KB ) - added by Ryan J Ollos <ryan.j.ollos@…> 6 years ago.
TriStateIE.png (3.9 KB ) - added by Ryan J Ollos <ryan.j.ollos@…> 6 years ago.

Download all attachments as: .zip

Change History (13)

by mokareem10@…, 6 years ago

Attachment: batch-modify-selection.png added

Select-all checkbox doesn't deselect

comment:1 by Ryan J Ollos <ryan.j.ollos@…>, 6 years ago

Cc: ryan.j.ollos@… added

This could be a result of a defect in #10992/[11505], however I can't reproduce in 1.0-stable-r11795 with Chromium 25 on Ubuntu. Which browser are you using? Do you see the tri-state behavior (#10992) in your browser? Any errors in the JavaScript error console?

in reply to:  1 comment:2 by anonymous, 6 years ago

Replying to Ryan J Ollos <ryan.j.ollos@…>:

This could be a result of a defect in #10992/[11505], however I can't reproduce in 1.0-stable-r11795 with Chromium 25 on Ubuntu. Which browser are you using? Do you see the tri-state behavior (#10992) in your browser? Any errors in the JavaScript error console?

I was browsing using IE 8. I just tried the same thing using Firefox (20.0.1) and I still have the same issue. I checked the error console in Firefox and don't see any errors/warnings when following the steps above.

Last edited 5 years ago by Ryan J Ollos (previous) (diff)

comment:3 by Christian Boos, 6 years ago

Definitely works for me, with either IE10 in IE8 mode (and even IE7 mode) or with a genuine IE8.

Are you sure the appropriate js code is used? Compare what your browser uses with the source:branches/1.0-stable/trac/htdocs/js/query.js file.

by Ryan J Ollos <ryan.j.ollos@…>, 6 years ago

Attachment: TriStateChrome.png added

by Ryan J Ollos <ryan.j.ollos@…>, 6 years ago

Attachment: TriStateIE.png added

in reply to:  3 ; comment:4 by Ryan J Ollos <ryan.j.ollos@…>, 6 years ago

Replying to cboos:

Are you sure the appropriate js code is used?

Are you thinking that an older version of the code might be cached (server-side?)?

I was also wondering about the possibility of a plugin conflict. I'd be interested to know if the batch modify checkbox is in the indeterminate state when some, but not all, of the ticket checkboxes are selected.

Chrome or Firefox:

Internet Explorer 10:

in reply to:  4 ; comment:5 by Christian Boos, 6 years ago

Replying to Ryan J Ollos <ryan.j.ollos@…>:

Replying to cboos:

Are you sure the appropriate js code is used?

Are you thinking that an older version of the code might be cached (server-side?)?

Yes, the dreaded #9936 issue ;-) (or simply a deploy not performed after an upgrade, if serving static resources)

I was also wondering about the possibility of a plugin conflict.

Yes, another possibility, anything resulting in a Javascript error happening before our code is executed, or anything preventing our code to be executed.

So even if the query.js code is the correct one, it would help to put a breakpoint at query.js, line 403, to see if it is reached at all.

Last edited 6 years ago by Christian Boos (previous) (diff)

in reply to:  5 ; comment:6 by anonymous, 6 years ago

Replying to cboos:

Replying to Ryan J Ollos <ryan.j.ollos@…>:

Replying to cboos:

Are you sure the appropriate js code is used?

Are you thinking that an older version of the code might be cached (server-side?)?

Yes, the dreaded #9936 issue ;-) (or simply a deploy not performed after an upgrade, if serving static resources)

I was also wondering about the possibility of a plugin conflict.

Yes, another possibility, anything resulting in a Javascript error happening before our code is executed, or anything preventing our code to be executed.

So even if the query.js code is the correct one, it would help to put a breakpoint at query.js, line 403, to see if it is reached at all.

Perhaps it is the issue identified in ticket #9936. I upgraded the Trac install from 0.11 to 1.0. From what I recall though, 0.11 didn't use JS at all, right? If that's the case, I assume it wouldn't be a server-side JS caching issue.

Looking back at the docs, I didn't update Python (missed this part TracUpgrade#UpgradingfromTrac0.11toTrac0.12). That said, I can't imagine that running an older version of Python should have any impact on the JS…thoughts?

I'll see if I can dig in a bit more to see if there is a plugin that might be affecting the JS. Is there anything else that you guys would suggest I look at?

cboos - you mentioned something about a deploy. Are you referring to TracUpgrade#a5.Refreshstaticresources? I didn't think that applied to my install so I didn't run that command.

Last edited 5 years ago by Ryan J Ollos (previous) (diff)

in reply to:  6 comment:7 by Ryan J Ollos <ryan.j.ollos@…>, 6 years ago

Replying to anonymous:

Perhaps it is the issue identified in ticket #9936. I upgraded the Trac install from 0.11 to 1.0. From what I recall though, 0.11 didn't use JS at all, right? If that's the case, I assume it wouldn't be a server-side JS caching issue.

Trac 0.11 utilized some JavaScript: tags/trac-0.11/trac/htdocs/js.

Looking back at the docs, I didn't update Python (missed this part TracUpgrade#UpgradingfromTrac0.11toTrac0.12). That said, I can't imagine that running an older version of Python should have any impact on the JS…thoughts?

Which version of Python are you running? Well, it probably doesn't matter, because Trac wouldn't install if you didn't meet the minimum Python version requirement: tags/trac-1.0/setup.py@:19-25#L15

I'll see if I can dig in a bit more to see if there is a plugin that might be affecting the JS. Is there anything else that you guys would suggest I look at?

Yes, what cboos suggested in comment:5. Try debugging into the JS code. Also, try disabling all your plugins and see if it works. And what about my question from comment:4?

cboos - you mentioned something about a deploy. Are you referring to TracUpgrade#a5.Refreshstaticresources? I didn't think that applied to my install so I didn't run that command.

Yes, that's right. Are you running tracd or a webserver such as Apache?

comment:8 by Ryan J Ollos, 6 years ago

Keywords: needinfo added

comment:9 by Ryan J Ollos, 6 years ago

Resolution: worksforme
Status: newclosed

Closing since there hasn't been any follow-up for more than 3 months.

comment:10 by Ryan J Ollos, 5 years ago

Similar issue after upgrade reported on the mailing list.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.