Edgewall Software
Modify

Opened 7 years ago

Closed 7 years ago

#11055 closed defect (duplicate)

OperationalError: database is locked

Reported by: mark Owned by:
Priority: normal Milestone:
Component: general Version: 0.12.3
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

How to Reproduce

While doing a GET operation on /login, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{}

User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:18.0) Gecko/20100101 Firefox/18.0

System Information

Trac 0.12.3
Trac 0.12.3
Babel 0.9.5
Docutils 0.7
Genshi 0.6
mod_wsgi 2.5 (WSGIProcessGroup trac_wsgi_07 WSGIApplicationGroup %{GLOBAL})
Pygments 1.4dev-20110115
pysqlite 2.4.1
Python 2.5.2 (r252:60911, Jan 24 2010, 18:02:01)
[GCC 4.3.2]
Python 2.5.2 (r252:60911, Jan 24 2010, 18:02:01)
[GCC 4.3.2]
pytz 2008c
pytz 2008c
RPC 1.1.2
setuptools 0.6c12
setuptools 0.6c12
SQLite 3.7.3
Subversion 1.7.8 (r1419691)
jQuery 1.4.4

Enabled Plugins

SecureSession 0.10dev-r1500
TracAnnouncer 0.12.1.dev
tracrpc.changeset N/A
TracXMLRPC 1.1.2

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/web/main.py", line 522, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/web/main.py", line 243, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/web/auth.py", line 115, in process_request
    self._do_login(req)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/web/auth.py", line 153, in _do_login
    @self.env.with_transaction()
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/db/api.py", line 77, in transaction_wrapper
    fn(ldb)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/web/auth.py", line 158, in store_session_cookie
    (int(time.time()) - 86400 * 10,))
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/db/util.py", line 65, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/db/sqlite_backend.py", line 78, in execute
    result = PyFormatCursor.execute(self, *args)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/db/sqlite_backend.py", line 56, in execute
    args or [])
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/db/sqlite_backend.py", line 48, in _rollback_on_error
    return function(self, *args, **kwargs)
OperationalError: database is locked

Attachments (0)

Change History (1)

comment:1 by Remy Blank, 7 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #10077, one of our MostFrequentDuplicates.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.