Edgewall Software
Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11047 closed defect (duplicate)

Trac 1.0.1 does not find babel

Reported by: anton Owned by:
Priority: highest Milestone:
Component: general Version:
Severity: normal Keywords: distribute setuptools
Cc: Branch:
Release Notes:
API Changes:

Description

I just updated from Trac 1.0.0 to 1.0.1 on my python 2.7 (32bit) trac on windows 7 64 bit.

I use german localisation which does not work ynamore in trac 1.0.1:

  • All is in english
  • In preferences I can't change the language and I see an error message:
    Note: Translations are currently unavailable. Trac has been localized to more than a dozen of languages but in order to be able to use them, the Babel package needs to be present when installing Trac. See TracInstall for details.

But my babel 0.9.6 *is* installed.

So I switch back to 1.0.0 and I see my german language again.

PS: I can't set the version to 1.0.1 in your trac because its missing!

Attachments (0)

Change History (13)

comment:1 by Christian Boos, 6 years ago

Version: 1.0.1

I just re-installed from scratch:

  • once with the win32.exe installer
  • once with from the .zip

In both cases, I could see the interface in German.

Now testing easy_install -U … maybe this is the problematic case.

comment:2 by anonymous, 6 years ago

Version: 1.0.1

Observation I made:

  • I installed trac-1.0.1 like trac 1.0.0 with
    python setup.py install
  • the created trac-1.0.0 egg has 3.5 MB, but the trac-1.0.1 egg has only 1.9 MB and when I look in the egg, I see that the "locale" directory is missing.

comment:3 by anton, 6 years ago

and … I downloaded the following trac: http://download.edgewall.org/trac/Trac-1.0.1.zip

in reply to:  1 comment:4 by Christian Boos, 6 years ago

Now testing easy_install -U … maybe this is the problematic case.

Hm, no. Even an easy_install -U Trac (on top of a 1.0 version installed via Trac-1.0.win32.exe) worked.

in reply to:  2 ; comment:5 by Christian Boos, 6 years ago

Replying to anonymous:

Observation I made:

  • I installed trac-1.0.1 like trac 1.0.0 with
    python setup.py install
  • the created trac-1.0.0 egg has 3.5 MB, but the trac-1.0.1 egg has only 1.9 MB and when I look in the egg, I see that the "locale" directory is missing.

Then you don't have Babel correctly installed.

From the same shell where you started python setup.py install, could you please do:

python -c 'import babel; print babel.__version__'

in reply to:  5 comment:6 by anton, 6 years ago

Replying to cboos:

Replying to anonymous:

Observation I made:

  • I installed trac-1.0.1 like trac 1.0.0 with
    python setup.py install
  • the created trac-1.0.0 egg has 3.5 MB, but the trac-1.0.1 egg has only 1.9 MB and when I look in the egg, I see that the "locale" directory is missing.

Then you don't have Babel correctly installed.

From the same shell where you started python setup.py install, could you please do:

python -c 'import babel; print babel.__version__'

Here is the result:

D:\install\python\trac\Trac-1.0>python -c "import babel; print babel.__version__"
0.9.6

… but wait: I just unzipped again the Trac-1.0.zip and did again python setup.py install in the unzipped Trac-1.0 directory…

now my Trac-1.0-py2.7.egg is only 1.9 MB too, so it seems to be something else (some python package I installed in the meantime) which interferes with the setup.py !

I have distribute-0.6.32-py2.7.egg installed, I will update to the new one and retry.

comment:7 by anton, 6 years ago

Hurra !

It works now:

  • I installed: distribute-0.6.34-py2.7.egg
  • I rebuild Trac-1.0.1 with python setup.py install
  • I see that the Trac-1.0.1-py2.7.egg has now 4.376.680 Bytes

I run it and I see my german again.

Merci Christian :-)

comment:8 by Christian Boos, 6 years ago

Which anton is this? ;-)

comment:9 by anonymous, 6 years ago

Anton Müller, you don't know me but I know you speak french :-)

comment:10 by anton, 6 years ago

Anyway I think you can close this ticket, or perhaps you want to add a note somewhere in the install docs.

From my part, you can close it.

comment:11 by Christian Boos, 6 years ago

Resolution: worksforme
Status: newclosed

Indeed I do, and I just happen to have a few Anton friends as well ;-)

And well, if we hear again about distribute issues, we'll indeed add a note to the install docs.

Have a nice day, and enjoy your 1.0.1 release!

comment:12 by bytesplit, 4 years ago

I had the same issue. Neither Babel 0.9 nor 1.3 seemed to work. The only variant which worked:

  • easy_install babel (will currently be 1.3)
  • easy_install genshi (currently 0.7)
  • easy_install trac will not work! no locales
  • download tgz source of Trac 1.0.1
  • python setup.py update_catalog

(this seems not done during install, but without it you'll end up without locales)

  • python setup.py install

FINALLY: Trac egg is around 4.2 megs and locales are there.

comment:13 by Jun Omae, 4 years ago

Keywords: distribute setuptools added
Resolution: worksformeduplicate

This issue is a duplicate of #11640, which is reproduced when it is installed by easy_install and egg file is created by bdist_egg.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.