Edgewall Software
Modify

Opened 8 years ago

Closed 8 years ago

#10996 closed defect (duplicate)

get_path_history raises NotImplementedError on mercurial repository

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: version control/log view Version: 1.1.1dev
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /log/jomae.hg/.tx/config, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'action': u'stop_on_copy',
 'limit': u'100',
 'mode': u'path_history',
 'path': u'/jomae.hg/.tx/config',
 'rev': u'e50931238feef5618bf7572f6859049431d08af3',
 'sfp_email': u'',
 'sfph_mail': u'',
 'stop_rev': u''}

User agent: Mozilla/5.0 (Linux; U; Android 2.3.4; en-us; myTouch_4G_Slide Build/GRJ22) AppleWebKit/533.1 (KHTML, like Gecko) Version/4.0 Mobile Safari/533.1

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/virtualenv/1.1dev/lib/python2.6/site-packages/Trac-1.1.1dev_r11429-py2.6.egg/trac/web/main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/virtualenv/1.1dev/lib/python2.6/site-packages/Trac-1.1.1dev_r11429-py2.6.egg/trac/web/main.py", line 214, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/virtualenv/1.1dev/lib/python2.6/site-packages/Trac-1.1.1dev_r11429-py2.6.egg/trac/versioncontrol/web_ui/log.py", line 172, in process_request
    for old_path, old_rev, old_chg in history():
  File "/usr/local/virtualenv/1.1dev/lib/python2.6/site-packages/Trac-1.1.1dev_r11429-py2.6.egg/trac/versioncontrol/web_ui/log.py", line 125, in history
    for h in repos.get_path_history(path, rev):
  File "/usr/local/virtualenv/1.1dev/lib/python2.6/site-packages/Trac-1.1.1dev_r11429-py2.6.egg/trac/versioncontrol/api.py", line 916, in get_path_history
    raise NotImplementedError
NotImplementedError

Attachments (0)

Change History (2)

comment:1 by anonymous, 8 years ago

Component: generalversion control/log view
Milestone: topic-multiprojectplugin - mercurial
Summary: NotImplementedError:get_path_history raises NotImplementedError on mercurial repository
Version: 1.0dev1.1.1dev

comment:2 by Peter Suter, 8 years ago

Milestone: plugin - mercurial
Resolution: duplicate
Status: newclosed

Duplicate of #9775.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.