Edgewall Software
Modify

Opened 8 years ago

Closed 7 years ago

#10955 closed defect (duplicate)

Trac Custom Report DO NOT Wikify Custom Field

Reported by: VYSE.NET@… Owned by: Christian Boos
Priority: normal Milestone:
Component: report system Version: 1.0dev
Severity: normal Keywords: custom wiki verify
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by Thijs Triemstra)

When add one column of custom field like this: SELECT … s.parent AS parent …

custom field (parent)'s format is wiki, but the report renders without wiki style.

This issue not exists in query page, seems below code in query.py fix this:

        wikify = set(f['name'] for f in self.fields 
                     if f['type'] == 'text' and f.get('format') == 'wiki')

        headers = [{
            'name': col, 'label': labels.get(col, _('Ticket')),
            'wikify': col in wikify,
            'href': self.get_href(context.href, order=col,
                                  desc=(col == self.order and not self.desc))
        } for col in cols]

Attachments (0)

Change History (3)

comment:1 by Thijs Triemstra, 8 years ago

Description: modified (diff)

comment:2 by Christian Boos, 8 years ago

Keywords: custom wiki verify added
Milestone: 1.0.2
Owner: set to Christian Boos
Status: newassigned

A proper patch would have been better, but the change looks good nevertheless…

comment:3 by Christian Boos, 7 years ago

Milestone: 1.0.2
Resolution: duplicate
Status: assignedclosed

Wait, that's no proposed change, just a reminder how it works in query.py. No wonder the code looks good, it's ours ;-)

Actually a duplicate of #8088.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.