Edgewall Software
Modify

Opened 6 years ago

Last modified 3 years ago

#10917 new defect

check semi-automatic bug reporting for plugins

Reported by: info@… Owned by:
Priority: low Milestone: next-major-releases
Component: general Version: 1.0
Severity: normal Keywords: plugin error
Cc: Ryan J Ollos
Release Notes:
API Changes:

Description

How to Reproduce

While doing a GET operation on /stats, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'path': '/'}

User agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.13 (KHTML, like Gecko) Chrome/24.0.1284.2 Safari/537.13

System Information

Trac 1.0
Babel 0.9.6
CustomFieldAdmin 0.2.6-r10460
Docutils 0.9.1
Genshi 0.6 (without speedups)
mod_python 3.3.1
Pygments 1.5
pysqlite 2.6.3
Python 2.7.3 (default, Oct 13 2012, 03:49:29)
[GCC 4.5.3]
pytz 2012f
setuptools 0.6
SQLite 3.7.14.1
Subversion 1.6.17 (r1128011)
jQuery 1.4.3

Enabled Plugins

ContextMenuPlugin 0.1
ExcelDownloadPlugin 0.12.0.1
FootNoteMacro 1.03-r11767
graphviz 0.7.5
RedirectsPlugin 0.1
SvnAuthzAdminPlugin 0.2
timingandestimationplugin 1.1.9
TracAccountManager 0.3.2
TracCollapsiblePlugin 0.1
TracCustomFieldAdmin 0.2.6-r10460
TracDateField 1.0.2-r10435
TracDiscussion 0.8
TracIncludeMacro 3.0.0dev-r12030
TracMasterTickets 3.0.2
TracMetrixPlugin 0.1.8
TracStats 0.4
TracTags 0.7dev-r12165
TracTicketChangelogPlugin 0.1
TracTocMacro 11.0.0.3
TracWorkflowAdmin 0.12.0.1

Python Traceback

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/trac/web/main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib64/python2.7/site-packages/trac/web/main.py", line 214, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib64/python2.7/site-packages/TracStats-0.4-py2.7.egg/tracstats/web_ui.py", line 162, in process_request
    result = self._process(req, cursor, where, data)
  File "/usr/lib64/python2.7/site-packages/TracStats-0.4-py2.7.egg/tracstats/web_ui.py", line 234, in _process
    td = datetime.timedelta(seconds=age)
OverflowError: normalized days too large to fit in a C int

Attachments (0)

Change History (10)

comment:1 Changed 6 years ago by Christian Boos

Resolution: cantfix
Status: newclosed

comment:2 Changed 6 years ago by Remy Blank

Didn't we add detection of plugins in stack traces at some point, and directed error reports to the plugin maintainer?

comment:3 Changed 6 years ago by Christian Boos

I did … and that was rejected at the time. Don't remember the rationale for the rejection though.

comment:4 Changed 6 years ago by Jun Omae

It seems the same as that issue reported in https://github.com/mrjbq7/tracstats/issues/36, which has been fixed.

comment:5 in reply to:  3 Changed 6 years ago by Christian Boos

Keywords: verify added
Resolution: cantfix
Status: closedreopened
Summary: OverflowError: normalized days too large to fit in a C intcheck semi-automatic bug reporting for plugins

Replying to cboos:

I did …

Ah, and I just see now that you had better chance than me with this and landed the feature in r9016. We should have a look why this didn't work. Maybe it's as simple as the contact information in that plugin not being filled correctly, maybe we indeed have a bug.

comment:6 Changed 6 years ago by Remy Blank

Right, so we only suggest a different Trac if the plugin info has a trac key (how do you do that, BTW?), or if its home_page or url points to Trac-Hacks. None of this is true for TracStatsPlugin.

comment:7 Changed 6 years ago by Remy Blank

And to answer my own question, there's actually no way to have a trac key in the plugin info, because get_pkginfo() only gets a limited set of attributes which doesn't contain trac, so it's no use trying to extract it in get_plugin_info(), and even less trying to use it in send_internal_error().

But it would be cool if there was :) The first step would probably be to find out how to add arbitrary keys to PKG-INFO from the call to setup().

comment:8 Changed 5 years ago by Christian Boos

Keywords: plugin error added; TracStats verify removed
Milestone: next-major-releases
Priority: normallow

comment:9 Changed 4 years ago by Ryan J Ollos

Cc: Ryan J Ollos added

comment:10 Changed 3 years ago by Ryan J Ollos

Status: reopenednew

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The ticket will remain with no owner.
The ticket will be disowned.
as The resolution will be set.
The owner will be changed from (none) to anonymous.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.