Edgewall Software
Modify

Opened 8 years ago

Closed 8 years ago

Last modified 6 years ago

#10894 closed defect (cantfix)

Not all recipients, specified in CC field, receive letters about ticket changes

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: notification Version: 0.12.3
Severity: normal Keywords: needinfo
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description (last modified by anonymous)

I specified 8 recipients, but only first 3 of them received letters

Attachments (0)

Change History (13)

comment:1 by iv@…, 8 years ago

Cc: iv@… removed

comment:2 by Remy Blank, 8 years ago

Component: generalnotification
Keywords: neednifo added

You'll need to give us much more information for us to be able to help. Please provide the recipient addresses and all the email-related settings in trac.ini.

comment:3 by anonymous, 8 years ago

CC: bronin, olya, nikolaeva, grachkov, osv_lana, dm_ivanov, illarionova, paimanova

track.ini related settings:
[notification]
admit_domains =
always_notify_owner = true
always_notify_reporter = true
always_notify_updater = true
ignore_domains =
mime_encoding = base64
smtp_always_bcc =
smtp_always_cc =
smtp_default_domain = keysystems.ru
smtp_enabled = true
smtp_from = trac_revizor@node2
smtp_from_name = trac_revizor
smtp_password =
smtp_port = 25
smtp_replyto = trac@localhost
smtp_server = webserver
smtp_subject_prefix = default
smtp_user =
ticket_subject_template = $prefix #$ticket.id: $summary
use_public_cc = false
use_short_addr = true
use_tls = false

comment:4 by anonymous, 8 years ago

Description: modified (diff)

comment:5 by Franz Mayer <franz.mayer@…>, 8 years ago

Did everyone of these CC-people have defined their email address in their preference page? Maybe only the three people, who received mails have entered their email address?!

comment:6 by anonymous, 8 years ago

Address defined: olya, grachkov, osv_lana, dn_ivanov, illarionova, paimanova
Address not defined: bronin, nikolaeva

  1. cc: bronin, olya, nikolaeva, grachkov, osv_lana, dm_ivanov, illarionova, paimanova
    received: bronin, olya, nikolaeva, grachkov, osv_lana
  1. cc: dm_ivanov, illarionova, paimanova, bronin, olya, nikolaeva, grachkov, osv_lana

received: dm_ivanov, illarionova, paimanova, bronin, olya, nikolaeva

  1. cc: bronin@…, olya@…, nikolaeva@…, grachkov@…, osv_lana@…, dm_ivanov@…, illarionova@…, paimanova@…

received: bronin, olya, nikolaeva, grachkov, osv_lana

comment:7 by anonymous, 8 years ago

Keywords: needinfo added; neednifo removed

Anything interesting in the log file? Any related plugins (e.g. Announcer) enabled?

comment:8 by iv@…, 8 years ago

log and plugins folders are empty

comment:9 by Christian Boos, 8 years ago

Resolution: worksforme
Status: newclosed

Well, as explained in the InstallationIssue page, you'll get more feedback if you'd ask for help on the Trac-users MailingList.

When the problem is better understood and in the case it's indeed a real bug in Trac, feel free to come back here and reopen.

comment:10 by iv@…, 8 years ago

Wait a minute, please! Log was disabled. Now it works:

...
2012-10-15 12:56:03,829 Trac[chrome] DEBUG: Prepare chrome data for request
2012-10-15 12:56:04,016 Trac[main] DEBUG: Dispatching <Request "GET '/chrome/common/collapsed.png'">
2012-10-15 12:56:20,111 Trac[main] DEBUG: Dispatching <Request "POST '/ticket/4222'">
2012-10-15 12:56:20,111 Trac[api] INFO: Synchronized '(default)' repository in 0.00 seconds
2012-10-15 12:56:20,111 Trac[session] DEBUG: Retrieving session for ID 'titov'
2012-10-15 12:56:21,002 Trac[notification] INFO: Sending notification through SMTP at webserver:25 to [u'iv@keysystems.ru', u'stepanov_d', u'bronin', u'grachkov@keysystems.ru', u'nikolaeva', u'olya@keysystems.ru', u'osv_lana@keysystems.ru', u'bronin@keysystems.ru', u'nikolaeva@keysystems.ru', u'dm_ivanov@keysystems.ru', u'illarionova@keysystems.ru', u'paimanova@keysystems.ru']
2012-10-15 12:56:21,986 Trac[main] DEBUG: Dispatching <Request "POST '/wiki_render'">
2012-10-15 12:56:21,986 Trac[api] INFO: Synchronized '(default)' repository in 0.00 seconds
2012-10-15 12:56:21,986 Trac[session] DEBUG: Retrieving session for ID 'titov'
2012-10-15 12:56:23,799 Trac[web_ui] DEBUG: Side effect for ConfigurableTicketWorkflow
2012-10-15 12:56:23,954 Trac[main] DEBUG: Dispatching <Request "GET '/ticket/4222'">
2012-10-15 12:56:23,970 Trac[api] INFO: Synchronized '(default)' repository in 0.02 seconds
2012-10-15 12:56:23,970 Trac[session] DEBUG: Retrieving session for ID 'titov'
2012-10-15 12:56:24,174 Trac[default_workflow] DEBUG: render_ticket_action_control: action "leave"
2012-10-15 12:56:24,174 Trac[default_workflow] DEBUG: render_ticket_action_control: action "resolve"
2012-10-15 12:56:24,188 Trac[default_workflow] DEBUG: render_ticket_action_control: action "reopen"
2012-10-15 12:56:24,220 Trac[chrome] DEBUG: Prepare chrome data for request
2012-10-15 12:56:24,782 Trac[main] DEBUG: Dispatching <Request "GET '/chrome/site/your_project_logo.png'">
2012-10-15 12:56:24,813 Trac[chrome] WARNING: File your_project_logo.png not found in any of ['d:\\trac\\revizor\\htdocs']
2012-10-15 12:56:24,813 Trac[main] WARNING: HTTPNotFound: 404 Not Found (File your_project_logo.png not found)
2012-10-15 12:56:24,813 Trac[session] DEBUG: Retrieving session for ID 'titov'
2012-10-15 12:56:24,813 Trac[chrome] DEBUG: Prepare chrome data for request
2012-10-15 12:56:55,720 Trac[main] DEBUG: Dispatching <Request "GET '/admin'">
...
Last edited 6 years ago by Jun Omae (previous) (diff)

comment:11 by iv@…, 8 years ago

Resolution: worksforme
Status: closedreopened

comment:12 by Remy Blank, 8 years ago

Resolution: cantfix
Status: reopenedclosed

So here's the list of recipients that is passed to the SMTP server.

2012-10-15 12:56:21,002 Trac[notification] INFO: Sending notification through SMTP at webserver:25 to [u'iv@keysystems.ru', u'stepanov_d', u'bronin', u'grachkov@keysystems.ru', u'nikolaeva', u'olya@keysystems.ru', u'osv_lana@keysystems.ru', u'bronin@keysystems.ru', u'nikolaeva@keysystems.ru', u'dm_ivanov@keysystems.ru', u'illarionova@keysystems.ru', u'paimanova@keysystems.ru']

This looks like the full list above, so this is an issue with your SMTP server.

comment:13 by iv@…, 8 years ago

Thanks for your hint and attention. It was SMTP server.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.