Edgewall Software
Modify

Opened 15 years ago

Closed 15 years ago

Last modified 13 years ago

#1086 closed defect (duplicate)

utf-8 encode for date string

Reported by: eightbit Owned by: Jonas Borgström
Priority: normal Milestone:
Component: general Version: 0.8
Severity: minor Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

in korean, date format is like this:

2004-12-26 오전 10:08:20 ('오전' means 'forenoon')

date string have 'forenoon' and 'afternoon'. so, date string should be encoded with 'utf-8'

in addition, korean charset name is 'euc-kr' it can use like this in python language:

util.to_utf8(strdate, 'euc-kr')

'euc-kr' can replace with default charset value in trac.ini. i think this code will not affect to other charset.

Attachments (0)

Change History (2)

comment:1 by Christopher Lenz, 15 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #1081.

comment:2 by Matthew Good, 14 years ago

Milestone: 0.9

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jonas Borgström.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jonas Borgström to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.