Edgewall Software
Modify

Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#10803 closed defect (worksforme)

trac 1.0beta from github does not upgrade cache table

Reported by: anonymous Owned by:
Priority: highest Milestone:
Component: database backend Version: 1.0dev
Severity: blocker Keywords:
Cc: leho@… Branch:
Release Notes:
API Changes:

Description (last modified by anonymous)

I found that while upgrading my existing trac instances from trac 0.12/0.13 to 1.0beta1 the upgrade is flawed in that db27.py will not be executed.

I have here trac instances using a database_version 27. On upgrade, trac will create a copy of the database file (sqlite that is) having a version identifier of 27.

It will then skip db27 and continue with db29.

In order to overcome this problem, one needs to

sqlite3 db/trac.db update system set value=26 where name = 'database_version';

and run trac <env> upgrade again…

Somebody must have "fucked up" the database migration path, as the last upgrade that I did using 0.12/0.13 already increased the database version to 27 and it did not introduce a third column to the cache table.

TIA for fixing this.

Attachments (0)

Change History (8)

comment:1 by anonymous, 7 years ago

Description: modified (diff)

comment:2 by anonymous, 7 years ago

Description: modified (diff)

comment:3 by lkraav <leho@…>, 7 years ago

Cc: leho@… added

comment:4 by Remy Blank, 7 years ago

Of course, if your database_version is already 27, Trac won't run db27.py. Or was this a typo, and you meant that it skipped db28.py?

in reply to:  4 comment:5 by anonymous, 7 years ago

Replying to rblank:

Of course, if your database_version is already 27, Trac won't run db27.py. Or was this a typo, and you meant that it skipped db28.py?

AFAIK there is no db28, just a db29.

And, yes, the db version was already at 27, so it skipped the db27 file. Since the db version was raised by a previous upgrade done using version 0.13, I wonder why that not already introduced the changes to the cache table…

comment:6 by anonymous, 7 years ago

there is a db28, just found it.

comment:7 by anonymous, 7 years ago

Just had a look at the repository, the db27.py file was added to 0.13dev a long time ago. I wonder what went wrong here that the db version was increased to 27 without the actual changes being applied.

I think that this might be an error that exists only on my machines and this must not necessarily be an issue that affects other people's trac instances.

Perhaps we should close this then…

comment:8 by Remy Blank, 7 years ago

Milestone: 1.0
Resolution: worksforme
Status: newclosed

Ok, thanks for the feedback. I'm closing this for now, please reopen if you can reproduce the issue.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.