Edgewall Software
Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10679 closed enhancement (fixed)

Set general purpose bit 11 for utf-8 encoded filename in a zip file

Reported by: Jun Omae Owned by: Jun Omae
Priority: normal Milestone: 0.12.4
Component: general Version: 0.12-stable
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

Now, Trac generates a zip file while downloading as zip in changeset and all attachments files as zip (0.13+). The filename of the zip file is encoded with utf-8. but "Language encoding flag" in zipinfo.flag_bits is unset.

If the bit is set, 7-zip extracts as unicode in Windows. If unset, it extracts broken filename. (confirmed on Windows XP.)

However, even if set, zip folder in Windows XP and 7 extracts broken filename.

Patches:

See also:

Attachments (2)

zip-filename-utf8-0.12.diff (766 bytes ) - added by Jun Omae 8 years ago.
zip-filename-utf8-trunk.diff (1.3 KB ) - added by Jun Omae 8 years ago.

Download all attachments as: .zip

Change History (5)

by Jun Omae, 8 years ago

Attachment: zip-filename-utf8-0.12.diff added

by Jun Omae, 8 years ago

comment:1 by Christian Boos, 8 years ago

We missed that convention when we talked about which encoding to use. Nice! So I suppose this would fix #4432?

in reply to:  1 comment:2 by Jun Omae, 8 years ago

Resolution: fixed
Status: newclosed

Committed in [11043/branches/0.12-stable] and [11044/trunk].

So I suppose this would fix #4432?

I think that it should keep open, because Zip folder in Windows cannot handle the bit.

I think that Windows users need "encoding for zip archive" option in trac.ini and user preference.

comment:3 by Jun Omae, 8 years ago

Owner: set to Jun Omae

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Jun Omae to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.