Edgewall Software
Modify

Opened 8 years ago

Closed 5 years ago

#10574 closed enhancement (duplicate)

add "statistical data update" as new ticket event type to already existing event type "comment"

Reported by: fbrettschneider@… Owned by:
Priority: normal Milestone:
Component: notification Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

Suggestion: Such new ticket event type implies to change Trac in a way that changes to special ticket fields which contain statistical data are not filed in a common ticket comment anymore but as "statistical data update" event. Then the email notification system could be setup to only deliver real comments instead of everything.

Background: All new events for a ticket are currently filed as "comment". Often comments will be sent to subscribers or involved people by email notification. Using project management plugins feeding custom ticket fields like "remaininghours", "workedhours" in e.g. daily iterations leads to many such statistical-data-update ticket comments (of adding/subtracting/changing hours). Email notification of such comments is experienced as spam.

Attachments (0)

Change History (4)

comment:1 by Ryan J Ollos <ryano@…>, 7 years ago

Keywords: notification added

Related to #8607.

comment:2 by Ryan J Ollos <ryano@…>, 7 years ago

Component: generalnotification
Keywords: notification removed

comment:3 by Christian Boos, 7 years ago

Milestone: undecided

All the tickets for {20} from last year have probably been seen multiple times by now, yet are still to be triaged…

comment:4 by Ryan J Ollos, 5 years ago

Milestone: undecided
Resolution: duplicate
Status: newclosed

Duplicate of #10326.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.