Edgewall Software
Modify

Opened 8 years ago

Closed 7 years ago

#10500 closed defect (worksforme)

Quotes in the ticket summary trigger UnicodeDecodeError

Reported by: tracbug@… Owned by:
Priority: low Milestone:
Component: rendering Version: 0.12.1
Severity: minor Keywords: needinfo
Cc: Branch:
Release Notes:
API Changes:

Description

If the double-quotes character (") is used inside a ticket summary, it is impossible to link such ticket from elsewhere.

Example: If the ticket nr. 1234 contains summary This is "a summary" and another ticket nr. 2345 has a comment See ticket:1234 for details Than the ticket nr. 2345 cannot be displayed. It shows the following error: Genshi UnicodeDecodeError error while rendering template (unknown template location)

Apparently, it is because the summary is put into the title attribute when linking and there are quotes inside quotes. Some escaping should be used.

I searched for this error and it does not seem to be reported before.

Attachments (0)

Change History (2)

comment:1 by Remy Blank, 8 years ago

Keywords: needinfo added

It works fine here with current 0.12-stable, quoting is correct. Please try to reproduce the issue with all plugins disabled. I don't remember having fixed any issues of this kind, but you may also want to update to 0.12.2, just in case.

comment:2 by Ryan J Ollos <ryano@…>, 7 years ago

Resolution: worksforme
Status: newclosed

I can't reproduce either and also suspect you have a PluginIssue.

Closing ticket per policy of closing tickets that don't have a response for a few months, described at TracTicketTriage#Howtohelp.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.