Edgewall Software
Modify

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#10405 closed enhancement (duplicate)

Disable notifications for individual changes

Reported by: anonymous Owned by:
Priority: low Milestone:
Component: notification Version:
Severity: minor Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

This feature request would probably solve some complaints about too many notification emails, while requiring only little configuration.

I suggest a checkbox on the ticket page, e.g above the commit button, labelled Do not send notifications for this change.

The default state is unchecked, so normally trac does send notifications. However, when making administrative changes (renaming keywords, renaming attachments, replacing cc by a registered user etc.) one can prevent unneccessary email floods.

Optionally, to prevent abuse, visibility of this checkbox could be restricted using privileges.

#2200 expressed a similar intention. The difference is that, with a checkbox it is up to the ticket editor to decide whether a change is trivial or not.

Attachments (0)

Change History (3)

comment:1 by Remy Blank, 8 years ago

Milestone: unscheduled

I see how this could be useful, yes. I'm not sure it belongs into Trac core, but currently it's difficult for a plugin to hook into the ticket notifications. We should at least add the necessary interfaces. IIRC the AnnouncerPlugin merge was tackling this, but the effort seems to be stalled.

Last edited 8 years ago by Remy Blank (previous) (diff)

comment:2 by Peter Suter, 7 years ago

Milestone: unscheduled
Resolution: duplicate
Status: newclosed

Duplicate of #8607.

comment:3 by Ryan J Ollos <ryan.j.ollos@…>, 7 years ago

As mentioned in #8607, the th:QuietPlugin provides the feature you are wanting, though you have to be using the th:AnnouncerPlugin.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.