Edgewall Software
Modify

Opened 8 years ago

Closed 8 years ago

#10319 closed defect (wontfix)

textarea Custom Fields colspan setting breaks the ticket layout

Reported by: tpollard@… Owned by:
Priority: normal Milestone:
Component: ticket system Version: 0.12.2
Severity: normal Keywords: layout ticket custom fields
Cc: Branch:
Release Notes:
API Changes:

Description

If you have any textarea custom fields they get set up with a colspan of three which breaks the layout in the ticket view. See the attached screenshot.

I think this may be related to #3109 since the same trac.ini custom-fields section causes a layout problem, though the problem is slightly different.

I've got a small one line hack that seems to fix it (see attached patch).

The custom-tickets section I've tested it with is:

[ticket-custom]
billable = checkbox
billable.label = Billable?
billable.order = 3
billable.value = 1
blockedby = text
blockedby.label = Blocked By
blocking = text
blocking.label = Blocking
cause_and_plan = textarea
cause_and_plan.cols = 68
cause_and_plan.label = Cause and Plan
cause_and_plan.rows = 10
cause_and_plan.value = ROOT CAUSE is ....  ACTION PLAN is ...
completed_by_date = text
completed_by_date.label = Complete By
completed_by_date.value = mm/dd/yyyy
estimatedhours = text
estimatedhours.label = Estimated Number of Hours
estimatedhours.order = 1
estimatedhours.value = 0
hours = text
hours.label = Add Hours to Ticket
hours.order = 2
hours.value = 0
totalhours = text
totalhours.label = Total Hours
totalhours.order = 4

Attachments (2)

ticket_box.patch (603 bytes ) - added by tpollard@… 8 years ago.
Simple patch.
ticket_broken_layout.png (34.2 KB ) - added by tpollard@… 8 years ago.
An example of the broken layout (see the red circled section)

Download all attachments as: .zip

Change History (3)

by tpollard@…, 8 years ago

Attachment: ticket_box.patch added

Simple patch.

by tpollard@…, 8 years ago

Attachment: ticket_broken_layout.png added

An example of the broken layout (see the red circled section)

comment:1 by tpollard@…, 8 years ago

Resolution: wontfix
Status: newclosed

I just realised this is only broken if I have the Timing and Estimation Plugin on, so it's most likely in that plugin rather than Trac itself.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.