Edgewall Software
Modify

Opened 10 years ago

Closed 7 years ago

Last modified 7 years ago

#10271 closed defect (duplicate)

set_owner not considering extra permissions

Reported by: Ruedi <ruedi.silvestri@…> Owned by:
Priority: normal Milestone:
Component: ticket system Version: 0.12dev
Severity: major Keywords: set_owner extra permission workflow restrict_owner
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

We created a custom Workflow according to Workflow documentation and assigned dedicated permissions using the optional tracopt.perm.config_perm_provider.ExtraPermissionsProvider which works fine in principle. The issue reported here is the fact that using .set_owner operation does not consider those users having assigned permissions via tracopt.perm.config_perm_provider.ExtraPermissionsProvider but only those having MODIFY_TICKET.

OS: CentOS 5.5 Python: 2.4

Attachments (0)

Change History (3)

comment:1 by Christian Boos, 8 years ago

Milestone: undecided

All the tickets for {20} from last year have probably been seen multiple times by now, yet are still to be triaged…

comment:2 by Ryan J Ollos, 7 years ago

Keywords: workflow restrict_owner added
Resolution: duplicate
Status: newclosed

To summarize, action.permissions specifies permissions that users must have to carry out the action and action.set_owner specifies a list of users that can be set as the ticket owner. The latter overrides the [ticket] restrict_owner setting. Conversely, when [ticket] restrict_owner = true and action.set_owner hasn't been specified, the select contains all users with a valid sessions that posses TICKET_MODIFY. It sounds like you would like to specify the permission that determines which users populate the list. For example, you might like to specify TICKER_OWNER as the permission that determines whether a user can own the ticket, and thus determines which usernames will populate the list.

If my interpretation of your request is correct, it is a duplicate of #3580.

comment:3 by Peter Suter, 7 years ago

Milestone: undecided

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.