Edgewall Software
Modify

Opened 11 years ago

Closed 8 years ago

Last modified 8 years ago

#10119 closed defect (duplicate)

DataError: (1406, "Data too long for column 'value' at row 1")

Reported by: christian.tauber@… Owned by:
Priority: normal Milestone:
Component: database backend Version: 0.12.1
Severity: normal Keywords: mysql
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a POST operation on /wiki/Test, Trac issued an internal error.

Used PlantUML inside a Trac wiki page

{{{ 
#!PlantUML 
@startuml
actor Bob #red
participant Alice
participant L
Alice->Bob: Authentication Request
Bob->Alice: Authentication Response
Bob->L: Log transaction
@enduml
}}}

Other PlantUML requests, like

{{{
#!PlantUML
@startuml
Alice->Alice: This is a signal to self.\nIt also demonstrates\nmultiline \ntext
Alice->Alice: This is a signal to self.\nIt also demonstrates\nmultiline \ntext
@enduml
}}}

worked.

Trac is running on Windows 2003, IIS 6 using AJP to tracd.

Request parameters:

{'__FORM_TOKEN': u'f2358d6282d7b69d6e7c065d',
 'action': u'edit',
 'comment': u'',
 'editrows': u'8',
 'from_editor': u'1',
 'page': u'Test',
 'preview': u'Vorschauseite',
 'scroll_bar_pos': u'59',
 'text': u'\xc4\xd6\xdc\xe4\xf6\xfc\xdf\u03bc\u03f4\r\nTest\r\n{{{\r\n#!PlantUML\r\n@startuml\r\nactor Bob #red\r\nparticipant Alice\r\nparticipant L\r\nAlice->Bob: Authentication Request\r\nBob->Alice: Authentication Response\r\nBob->L: Log transaction\r\n@enduml\r\n}}}\r\n',
 'version': u'7'}

User agent: #USER_AGENT#

System Information

Trac 0.12.1
Babel 0.9.5
CustomFieldAdmin 0.2.5
Docutils 0.7
Genshi 0.6
MySQL server: "5.1.52-community", client: "5.1.33", thread-safe: 1
MySQLdb 1.2.2
Pygments 1.3.1
Python 2.6.6 (r266:84297, Aug 24 2010, 18:46:32) [MSC v.1500 32 bit (Intel)]
pytz 2010o
setuptools 0.6c11
Subversion 1.6.13 (r1002816)
jQuery #JQUERY#

Enabled Plugins

autocompleteusers 0.4.1
ChildNav N/A
ColorMacro Rev
footnotemacro 1.03
graphviz 0.7.6dev
notebox 0.1.dev
PlannedMilestones Rev
plantuml 1.2
traccustomfieldadmin 0.2.5
tracextracturl 0.3
trackeywordsuggest 0.2
tracmindmapmacro 0.4
tractocmacro 11.0.0.3
tracwikiprintplugin 1.8.4
UserStats Rev

Python Traceback

Traceback (most recent call last):
  File "C:\Python26\lib\site-packages\trac-0.12.1-py2.6-win32.egg\trac\web\main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "C:\Python26\lib\site-packages\trac-0.12.1-py2.6-win32.egg\trac\web\main.py", line 260, in dispatch
    req.session.save()
  File "C:\Python26\lib\site-packages\trac-0.12.1-py2.6-win32.egg\trac\web\session.py", line 88, in save
    @self.env.with_transaction()
  File "C:\Python26\lib\site-packages\trac-0.12.1-py2.6-win32.egg\trac\db\api.py", line 77, in transaction_wrapper
    fn(ldb)
  File "C:\Python26\lib\site-packages\trac-0.12.1-py2.6-win32.egg\trac\web\session.py", line 117, in delete_session_cookie
    """, attrs)
  File "C:\Python26\lib\site-packages\trac-0.12.1-py2.6-win32.egg\trac\db\util.py", line 85, in executemany
    return self.cursor.executemany(sql_escape_percent(sql), args)
  File "C:\Python26\lib\site-packages\MySQLdb\cursors.py", line 218, in executemany
    r = self._query('\n'.join([query[:p], ',\n'.join(q), query[e:]]))
  File "C:\Python26\lib\site-packages\MySQLdb\cursors.py", line 312, in _query
    rowcount = self._do_query(q)
  File "C:\Python26\lib\site-packages\MySQLdb\cursors.py", line 276, in _do_query
    db.query(q)
DataError: (1406, "Data too long for column 'value' at row 1")

Attachments (0)

Change History (5)

comment:1 by Remy Blank, 11 years ago

If this only happens with PlantUML markup, please report the issue to the PlantUML plugin maintainer. It seems that some session data is too large, so this may also be unrelated to the plugin.

comment:2 by anonymous, 11 years ago

Well, maybe it's an issue with the communication between the Browser - SSL - IIS 6 - tracd. I will search for issues with the configuration there.

comment:3 by Christian Boos, 10 years ago

Milestone: undecided

All the tickets for {20} from last year have probably been seen multiple times by now, yet are still to be triaged…

comment:4 by Jun Omae, 8 years ago

Component: generaldatabase backend
Keywords: mysql added
Milestone: undecided
Resolution: duplicate
Status: newclosed

A duplicate of #8396 and #11285.

session.value column is TEXT type when MySQL is used. Max length of TEXT type is 65535 characters.

in reply to:  1 comment:5 by Ryan J Ollos, 8 years ago

Replying to rblank:

If this only happens with PlantUML markup, please report the issue to the PlantUML plugin maintainer. It seems that some session data is too large, so this may also be unrelated to the plugin.

As a side note, PlantUmlMacro no longer stores the diagrams in session data (since [th 11255]).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.