Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#10039 closed defect (fixed)

Error when searching a certain string

Reported by: wolfisch Owned by: Christian Boos
Priority: highest Milestone: 0.12.3
Component: wiki system Version: 0.12
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

The following search string causes an error when it is searched for on Trac. This could be reproduce on this (official) Trac site. Just try to search for ||' (i.e. two vertical lines followed by an apostrophe).

According to Jonas, this may be a bug in the search parser.

Attachments (0)

Change History (5)

comment:1 by Christian Boos, 11 years ago

Component: generalwiki system
Milestone: 0.12.3
Priority: normalhighest
Version: 0.12

Oops, thanks for the report!

comment:2 by Remy Blank, 11 years ago

Confirmed. This seems to be due to Trac trying to format the string as WikiFormatting. We should probably catch the exception and revert to plain text in that case.

comment:3 by Christian Boos, 11 years ago

[OT] Envname custom field?!? Must be a side-effect of r10565

comment:4 by Christian Boos, 11 years ago

Resolution: fixed
Status: newclosed

Should be fixed in r10578 / r10579.

A "cleaner" fix would have been to disable unneeded rules in the LinkFormatter, as we do in InlineFormatter, but this is shorter, and more robust should additional rules depend on self.line in the future.

comment:5 by Christian Boos, 11 years ago

Owner: set to Christian Boos

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.