Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#9992 closed defect (worksforme)

IntegrityError: (1062, "Duplicate entry '7389-flusso/achievo/trunk/www/atk/attributes/fck/editor/dialog/f' for key 'rev'")

Reported by: a.huseman@… Owned by:
Priority: normal Milestone:
Component: general Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /newticket, Trac issued an internal error.

I don't know how this situation started. From one moment to another, I got this error. I tried restarting the webserver (apache), but that didn't solve the problem. No matter what action I take, logging on, browsing source, creating a new ticket, going to wiki… Always the same error occurs. I hope you have suggestions on how to solve this issue. Best regards, Ard Huseman, Flusso B.V.

User Agent was: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_6; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.237 Safari/534.10

System Information

Trac 0.11.6rc1
Python 2.6.4 (r264:75706, Oct 29 2009, 15:53:16)
[GCC 4.4.1]
setuptools 0.6c11
MySQL server: "5.1.37-1ubuntu5.1", client: "5.1.37", thread-safe: 1
MySQLdb 1.2.2
Genshi 0.5.1
mod_python 3.3.1
Subversion 1.6.5 (r38866)
RPC 1.0.6
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.6rc1-py2.6.egg/trac/web/main.py", line 450, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.6rc1-py2.6.egg/trac/web/main.py", line 176, in dispatch
    chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.6rc1-py2.6.egg/trac/web/main.py", line 296, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.6rc1-py2.6.egg/trac/versioncontrol/api.py", line 86, in pre_process_request
    self.get_repository(req.authname).sync()
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.6rc1-py2.6.egg/trac/versioncontrol/cache.py", line 215, in sync
    path, kind, action, bpath, brev))
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.11.6rc1-py2.6.egg/trac/db/util.py", line 64, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib/pymodules/python2.6/MySQLdb/cursors.py", line 166, in execute
    self.errorhandler(self, exc, value)
  File "/usr/lib/pymodules/python2.6/MySQLdb/connections.py", line 35, in defaulterrorhandler
    raise errorclass, errorvalue
IntegrityError: (1062, "Duplicate entry '7389-flusso/achievo/trunk/www/atk/attributes/fck/editor/dialog/f' for key 'rev'")

Attachments (0)

Change History (5)

comment:1 by Christian Boos, 11 years ago

See the MySqlDb page, "… check character set settings for your database".

You probably have a utf_ci collation, which triggers the #4378 issue.

See on the same page how you can fix this, MySqlDb#Collationfromwhatevertoutf8_bin.

comment:2 by a.huseman@…, 11 years ago

Resolution: fixed
Status: newclosed

I updated this ticket, but the update seems to be lost somewhere.

The issue was a field in the 'system' table, called 'youngest_rev'. The number was 7388 and we increased it manually to 7389. Last friday I comitted e new repository, which resulted in a 15mb email. Perhaps something couldn't be processed which resulted in not increasing 'youngest_rev'. At the moment, trac is functioning again.

comment:3 by Remy Blank, 11 years ago

Resolution: fixedworksforme

comment:4 by Christian Boos, 11 years ago

Then it might have been #8067… just for confirmation, are you using MyISAM tables?

comment:5 by a.huseman@…, 11 years ago

No, our database uses InnoDB tables, but indeed, the issue looks al lot like #8067

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.