Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

#9966 closed defect (duplicate)

TypeError: sequence item 0: expected string, LazyProxy found

Reported by: alexander.wenzel@… Owned by:
Priority: normal Milestone:
Component: general Version: 0.12.1
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /ticket/1, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'id': u'1'}

User agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

System Information

Trac 0.12.1
Agilo 0.9.1
Babel 0.9.5 (translations unavailable)
Genshi 0.6
Pygments 0.10
pysqlite 2.4.1
Python 2.5.2 (r252:60911, Jan 24 2010, 17:44:40)
[GCC 4.3.2]
pytz 2008c
setuptools 0.6c11
SQLite 3.5.9
Subversion 1.5.1 (r32289)
jQuery 1.4.2

Enabled Plugins

agilo 0.9.1
TracAccountManager 0.2.1dev

Python Traceback

Traceback (most recent call last):
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-x86_64/egg/trac/ticket/web_ui.py", line 169, in process_request
    return self._process_ticket_request(req)
  File "/usr/lib/python2.5/site-packages/agilo-0.9.1-py2.5.egg/agilo/ticket/web_ui.py", line 224, in _process_ticket_request
    template, data, content_type = super(AgiloTicketModule, self)._process_ticket_request(req)
  File "build/bdist.linux-x86_64/egg/trac/ticket/web_ui.py", line 569, in _process_ticket_request
    get_reporter_id(req, 'author'), field_changes)
  File "build/bdist.linux-x86_64/egg/trac/ticket/web_ui.py", line 1518, in _insert_ticket_data
    req, ticket, action)
  File "build/bdist.linux-x86_64/egg/trac/ticket/default_workflow.py", line 321, in render_ticket_action_control
    return (this_action['name'], tag(*control), '. '.join(hints))
TypeError: sequence item 0: expected string, LazyProxy found

Attachments (0)

Change History (2)

comment:1 by anonymous, 12 years ago

Already tried to fix it with reinstalling trac after babel…

comment:2 by Remy Blank, 12 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #9699.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.