Edgewall Software
Modify

Opened 9 years ago

Closed 5 years ago

#9884 closed defect (worksforme)

Notification email sent only to the last recipient of the list when smtp_default_domain is not empty

Reported by: sukender@… Owned by:
Priority: normal Milestone:
Component: notification Version: 0.12-stable
Severity: normal Keywords: smtp_default_domain needinfo
Cc: Emmanuel Blot Branch:
Release Notes:
API Changes:

Description

I made notifications tests (on a ticket change) and had:

Content of the "CC" field smtp_default_domain Result: email sent to…
user1, user2 mydomain.com only user2
user1, user2 @mydomain.com mydomain.com only user2
user1 @mydomain.com, user2 mydomain.com both
user1 @mydomain.com, user2 (empty) both
user1, user2 (empty) both

I guess the correct behavior would be to send both emails in all configurations. Am I right? And given the fact that changing smtp_default_domain give different results, this does not seem to be a mailer program issue.

Please note:

  • Users have their correct email address set in their preferences.
    • Addresses are all like [trac username]@[smtp_default_domain], and are valid.
  • All "always send notification if…" are disabled.
  • Trac version = 0.12.1, OS = debian, mailer = sendmail.
  • I've added a space before '@' in this ticket to avoid hidding "@mydomain.com" :)

This has to be tested on another system I guess… Please let me know if this can be reproduced.

Thanks.

Attachments (0)

Change History (6)

comment:1 by sukender@…, 9 years ago

Forgot to mention:

  • Trac is on a server whose address is subdomain.mydomain.com
  • However, the mydomain.com resolves to another address

comment:2 by Christian Boos, 9 years ago

Cc: Emmanuel Blot added
Keywords: smtp_default_domain added
Milestone: next-minor-0.12.x

(the notification subsystem desperately needs a maintainer… :-) )

comment:3 by Ryan J Ollos, 5 years ago

Keywords: needinfo added

The behaviour changed after [10347]. Now the smtp_default_domain will only be appended to the username if an email address is not found in the email_map (which would be the case if the user has not set their email address preference).

I was unable to reproduce with either Trac 0.12 or 1.0-stable.

The most valuable piece of information you could provide would be obtained by setting TracLogging level to INFO:

01:10:18 AM Trac[notification] INFO: Sending notification through SMTP at smtp.gmail.com:587 to [u'user1@gmail.com', u'user2@gmail.com']

I know it has been 4 years now, but are you able to provide any more info, or are you still running Trac and seeing the issue? Sorry for the delay!

Last edited 5 years ago by Ryan J Ollos (previous) (diff)

comment:4 by Ryan J Ollos, 5 years ago

Summary: Notification email sent only to the last recepient of the list when smtp_default_domain is not emptyNotification email sent only to the last recipient of the list when smtp_default_domain is not empty

comment:5 by sukender@…, 5 years ago

Thanks for trying to reproduce. To be true, I've updated to 1.0.1-dev long time ago, and I have no more trouble. I suspect this issue to have disappeared, and I suggest to close the ticket.

comment:6 by Ryan J Ollos, 5 years ago

Milestone: next-minor-0.12.x
Resolution: worksforme
Status: newclosed

Thank you for the quick follow-up. It's nice to be able to close out an old ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.