Edgewall Software
Modify

Opened 15 years ago

Closed 14 years ago

Last modified 13 years ago

#987 closed defect (fixed)

"Viev rev:" value reused when not expected - quite confusing

Reported by: mdc @… Owned by: Christian Boos
Priority: normal Milestone: 0.10
Component: version control/browser Version: 0.8
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

We have done a test-conversion of an existing repository into SVN using cvs2svn.

While browsing the result with Trac, I observed that some files in trunk were not the newest! They were shown correctly in the corresponding tags path.

After some clicking "Back" and "Next" in IE, I found out that the entry field "View rev:" (top right, normally updated automatically) was at "10108". Clearing the field and reloading the page gave the correct output.

A lot of "Back" clicking revealed, that it had been "sticky" at that value since I clicked that number (with a "View revision log" pop up) in a file listing. After that I probably used the "Back" button.

After that all subsequent Trac operations were relative to that revision! Dunno what was intended, but this is confusing.

Attachments (0)

Change History (4)

comment:1 by mdc, 15 years ago

Just cross checked with your installation, running 0.8. The user interface has been changed, "Viev rev:" selection no longer there, so maybe the problem is not relevant after 0.8?

comment:2 by mdc, 15 years ago

Version: 0.7.10.8

Problem seen on version 0.8 too. (Debian package.)

comment:3 by Christian Boos, 14 years ago

Milestone: 0.10
Owner: changed from Jonas Borgström to Christian Boos

In the TracBrowser, if the revision is not specified, the current revision number corresponding to the head will be used instead. The problem here is that once the revision is set, it remains sticky, as you said.

One way to be sure to stay on the head is to explicitely specify "head" for the viewed revision, in this View revision: field.

The Browse Source link should probably do this, in a VersioningSystemBackend independent way, though.

comment:4 by Christian Boos, 14 years ago

Resolution: fixed
Status: newclosed

This was fixed in r3099.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Christian Boos.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from Christian Boos to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.