Edgewall Software
Modify

Opened 9 years ago

Closed 9 years ago

#9739 closed defect (duplicate)

IntegrityError: (1062, "Duplicate entry 'priority-\xeb\xa7\xa4\xec\x9a\xb0\xec\x82\xac\xec\x86\x8c\xed\x95\xa8' for key 'PRIMARY'")

Reported by: admin01 Owned by:
Priority: normal Milestone:
Component: general Version: 0.12.1
Severity: normal Keywords: mysql
Cc: Branch:
Release Notes:
API Changes:

Description

How to Reproduce

While doing a POST operation on /admin/ticket/priority/trivial, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'd233ac8efe427316562ae0aa',
 'cat_id': u'ticket',
 'name': u'\ub9e4\uc6b0\uc0ac\uc18c\ud568',
 'panel_id': u'priority',
 'path_info': u'trivial',
 'save': u'\uc800\uc7a5\ud558\uae30'}

User agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; ko; rv:1.9.1.15) Gecko/20101026 Firefox/3.5.15

System Information

Trac 0.12.1
Babel 1.0dev-r546
Docutils 0.7
Genshi 0.7dev-r1134
mod_python 3.3.1
MySQL server: "5.1.34-community", client: "5.0.27", thread-safe: 1
MySQLdb 1.2.2
Pygments 1.3.1
Python 2.5.2 (r252:60911, Feb 21 2008, 13:11:45) [MSC v.1310 32 bit (Intel)]
RPC 1.1.0-r9360
setuptools 0.6c11
Subversion 1.6.9 (r901367)
jQuery 1.4.2

Enabled Plugins

iniadmin 0.2
tracaccountmanager 0.2.1dev-r9290
trachttpauth 1.1
tracpermredirect 2.0
tracxmlrpc 1.1.0-r9360

Python Traceback

Traceback (most recent call last):
  File "build\bdist.win32\egg\trac\web\main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "build\bdist.win32\egg\trac\web\main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "build\bdist.win32\egg\trac\admin\web_ui.py", line 116, in process_request
    path_info)
  File "build\bdist.win32\egg\trac\ticket\admin.py", line 53, in render_admin_panel
    return self._render_admin_panel(req, cat, page, version)
  File "build\bdist.win32\egg\trac\ticket\admin.py", line 610, in _render_admin_panel
    enum.update()
  File "build\bdist.win32\egg\trac\ticket\model.py", line 736, in update
    @self.env.with_transaction(db)
  File "build\bdist.win32\egg\trac\db\api.py", line 77, in transaction_wrapper
    fn(ldb)
  File "build\bdist.win32\egg\trac\ticket\model.py", line 743, in do_update
    """, (self.name, self.value, self.type, self._old_name))
  File "build\bdist.win32\egg\trac\db\util.py", line 65, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "C:\VisualSVN\trac\python\lib\site-packages\mysql_python-1.2.2-py2.5-win32.egg\MySQLdb\cursors.py", line 166, in execute
    self.errorhandler(self, exc, value)
  File "C:\VisualSVN\trac\python\lib\site-packages\mysql_python-1.2.2-py2.5-win32.egg\MySQLdb\connections.py", line 35, in defaulterrorhandler
    raise errorclass, errorvalue
IntegrityError: (1062, "Duplicate entry 'priority-\xeb\xa7\xa4\xec\x9a\xb0\xec\x82\xac\xec\x86\x8c\xed\x95\xa8' for key 'PRIMARY'")

Attachments (0)

Change History (2)

comment:1 by Remy Blank, 9 years ago

Keywords: needinfo added

Looks like a race condition on a double-submit. Is this error persistent, or was it a one-off?

comment:2 by Christian Boos, 9 years ago

Keywords: mysql added; needinfo removed
Resolution: duplicate
Status: newclosed

Looks like a duplicate of #4378 to me…

(@admin01: read the MySqlDb page and fix the database encoding as explained there)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.