Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

#9679 closed defect (worksforme)

SubversionException: ("File not found: revision 20388, path '/www/my/trunk/web/xEIyr5w9XAnOfTcL9je94w--.html'", 160013)

Reported by: wschultz@… Owned by:
Priority: high Milestone:
Component: version control Version: 0.12
Severity: normal Keywords: svn16
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /browser, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'path': '/'}

User agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/7.0.549.0 Safari/534.10

System Information

Trac 0.12
Genshi 0.6
mod_python 3.2.8
pysqlite 2.3.3
Python 2.4.3 (#1, Sep 3 2009, 15:37:37)
[GCC 4.1.2 20080704 (Red Hat 4.1.2-46)]
setuptools 0.6c11
SQLite 3.3.6
Subversion 1.6.12 (r955767)
jQuery 1.4.2

Enabled Plugins

navadd N/A
TracAccountManager 0.2.1dev-r7737
ZTicketDelete 0.1

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 513, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 200, in dispatch
    chosen_handler)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 346, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "/usr/lib/python2.4/site-packages/trac/versioncontrol/api.py", line 332, in pre_process_request
    repo.sync()
  File "/usr/lib/python2.4/site-packages/trac/versioncontrol/cache.py", line 240, in sync
    @self.env.with_transaction()
  File "/usr/lib/python2.4/site-packages/trac/db/api.py", line 77, in transaction_wrapper
    fn(ldb)
  File "/usr/lib/python2.4/site-packages/trac/versioncontrol/cache.py", line 269, in do_transaction
    for path, kind, action, bpath, brev in cset.get_changes():
  File "/usr/lib/python2.4/site-packages/trac/versioncontrol/svn_fs.py", line 883, in get_changes
    repos.svn_repos_replay(root, e_ptr, e_baton, pool())
  File "/usr/lib64/python2.4/site-packages/libsvn/repos.py", line 318, in svn_repos_replay
    return apply(_repos.svn_repos_replay, args)
SubversionException: ("File not found: revision 20388, path '/www/my/trunk/web/xEIyr5w9XAnOfTcL9je94w--.html'", 160013)

Attachments (0)

Change History (8)

comment:1 by anonymous, 12 years ago

Hey there, looks like a recent subversion update completely mangled my trac install. Every page produces the same error:

'SubversionException: ("File not found: revision 20388, path '/www/my/trunk/web/xEIyr5w9XAnOfTcL9je94w—.html'", 160013)'

I'm curious if it's because the file has two dashes in the name? Hopefully somebody could pass along some advise.

Thank you.

comment:2 by Christian Boos, 12 years ago

Component: generalversion control
Keywords: svn16 needinfo added

How's the repository itself? Can you get that revision via svn log -v -r 20388? And svn diff -r 20387:20388?

comment:3 by anonymous, 12 years ago

things look fine in the repository, but trac-admin repository resync gives the same error when it hits 20388. Could it be the changed path in the subversion revision?

[me@trac2 ~] 2$ svn log —verbose file:///var/svn/pcw/ -r 20388 r20388 | cmckeegan | 2010-10-08 13:05:18 -0700 (Fri, 08 Oct 2010) | 3 lines Changed paths:

A /www/pcw/trunk/web/googlefc2e49213e00ccaa.html A /www/pcw/trunk/web/xEIyr5w9XAnOfTcL9je94w—.html

comment:4 by atrice@…, 12 years ago

trac-admin resync with only this revision specified succeeds, but resyncing the entire repository fails at this revision:

$ trac-admin /var/trac/pcw repository resync "(default)" 20388 20388 resynced on (default).

$ trac-admin /var/trac/pcw repository resync "(default)" Resyncing repository history for (default)… SubversionException: ("File not found: revision 20388, path '/www/pcw/trunk/web/xEIyr5w9XAnOfTcL9je94w—.html'", 160013)

comment:5 by Christian Boos, 12 years ago

Keywords: verify added; needinfo removed
Milestone: next-minor-0.12.x
Priority: normalhigh

Oops, forgot about this ticket. Well, obviously we had no clue at that time and still don't have. Did you find out what was going by any chance?

I'll try to add a '/www/pcw/trunk/web/xEIyr5w9XAnOfTcL9je94w—.html' file in a test repository, but I don't see any reason why it should fail.

comment:6 by anonymous, 12 years ago

Oh, I believe the file had a space in it where svn didn't seem to mind but trac couldn't handle it. We had roll back svn and replay this specific commit without the space and all was well.

comment:7 by Liam Clancy (metafeather) <trac@…>, 12 years ago

I've had this exact same problem and would say its probably not a Trac issue.

In my case a file had been commited (somehow?) as ...deploy/bin/create-adapter-keystore.sh%0a

Whilst SVN appears to handle the commit with a space or newline at the end of the path, it (in my case) svnadmin would not verify the commit and dumps would fail.

comment:8 by Christian Boos, 12 years ago

Keywords: verify removed
Milestone: next-minor-0.12.x
Resolution: worksforme
Status: newclosed

Thanks for the feedback!

Would be nice if the original reporter could try a dump or a verify with svnadmin. On my side, I created a repository with a www/pcw/trunk/web/xEIyr5w9XAnOfTcL9je94w--.html file, no problem for trac-admin resync, as expected.

Resyncing repository history for test9679...
4 revisions cached.
Done.

See demo-0.13:r4/test9679.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.