Edgewall Software
Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#9647 closed defect (duplicate)

Exception after installing Babel

Reported by: Sebastian Krysmanski <sebastian@…> Owned by:
Priority: normal Milestone:
Component: general Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

After installing Babel (using easy_install), running Trac using tracd gives me the following stacktrace (before installing Babel everything worked fine):

Traceback (most recent call last):
  File "/srv/subversion/tracsandbox/lib/python2.6/site-packages/Trac-0.12-py2.6.egg/trac/web/api.py", line 436, in send_error
    data, 'text/html')
  File "/srv/subversion/tracsandbox/lib/python2.6/site-packages/Trac-0.12-py2.6.egg/trac/web/chrome.py", line 809, in render_template
    data = self.populate_data(req, data)
  File "/srv/subversion/tracsandbox/lib/python2.6/site-packages/Trac-0.12-py2.6.egg/trac/web/chrome.py", line 732, in populate_data
    'locale': req and req.locale,
  File "/srv/subversion/tracsandbox/lib/python2.6/site-packages/Trac-0.12-py2.6.egg/trac/web/api.py", line 212, in __getattr__
    value = self.callbacks[name](self)
  File "/srv/subversion/tracsandbox/lib/python2.6/site-packages/Trac-0.12-py2.6.egg/trac/web/main.py", line 307, in _get_locale
    translation.get_available_locales()]
  File "/srv/subversion/tracsandbox/lib/python2.6/site-packages/Trac-0.12-py2.6.egg/trac/util/translation.py", line 329, in get_available_locales
    in pkg_resources.resource_listdir('trac', 'locale')
  File "/srv/subversion/tracsandbox/lib/python2.6/site-packages/setuptools-0.6c11-py2.6.egg/pkg_resources.py", line 900, in resource_listdir
    resource_name
  File "/srv/subversion/tracsandbox/lib/python2.6/site-packages/setuptools-0.6c11-py2.6.egg/pkg_resources.py", line 1191, in resource_listdir
    return self._listdir(self._fn(self.module_path,resource_name))
  File "/srv/subversion/tracsandbox/lib/python2.6/site-packages/setuptools-0.6c11-py2.6.egg/pkg_resources.py", line 1282, in _listdir
    return os.listdir(path)
OSError: [Errno 2] No such file or directory: '/srv/subversion/tracsandbox/lib/python2.6/site-packages/Trac-0.12-py2.6.egg/trac/locale'

Attachments (0)

Change History (2)

comment:1 by Remy Blank, 9 years ago

Resolution: duplicate
Status: newclosed

This is a duplicate of #9439. As a workaround, you can de-install Trac, and re-install after installing Babel.

The fix we already have in 0.12-stable seems to be incomplete, so I'll need to work on it some more.

comment:2 by Sebastian Krysmanski <sebastian@…>, 9 years ago

You simply need to check whether this directory exists. I've created the directory afterwards and the error disappeared.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.