Edgewall Software
Modify

Opened 9 years ago

Closed 2 years ago

#9629 closed enhancement (fixed)

Publish T.E.O site layout in CookBook

Reported by: Itamar Ostricher Owned by:
Priority: normal Milestone:
Component: general Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description

As discussed on mailing list thread

Thanks :-)

Attachments (6)

site.html (2.3 KB ) - added by Remy Blank 9 years ago.
Site template
projects.css (5.0 KB ) - added by Remy Blank 9 years ago.
Common CSS for all projects
site_leftbox.html (384 bytes ) - added by Remy Blank 9 years ago.
Menu on the left
site_newticket.cs (1.2 KB ) - added by Remy Blank 9 years ago.
Notice at the top of the "new ticket" page
admin-page-winxp-chrome.PNG (57.0 KB ) - added by Itamar Ostricher 9 years ago.
quirk in admin page with t.e.o layout using Chrome & WinXP
admin-page-win7-chrome.png (71.7 KB ) - added by Itamar Ostricher 9 years ago.
quirk in admin page with t.e.o layout using Chrome and Firefox3 with Win7 or IE8 with WinXP

Download all attachments as: .zip

Change History (19)

comment:1 by Remy Blank, 9 years ago

If I provide the files, will you turn them into a cookbook entry?

in reply to:  1 comment:2 by Itamar Ostricher, 9 years ago

Replying to rblank:

If I provide the files, will you turn them into a cookbook entry?

sure, why not.

comment:3 by Remy Blank, 9 years ago

Milestone: not applicable
Owner: set to Remy Blank

Deal. I'll need to strip out a few things first, though (Google ads stuff).

by Remy Blank, 9 years ago

Attachment: site.html added

Site template

by Remy Blank, 9 years ago

Attachment: projects.css added

Common CSS for all projects

by Remy Blank, 9 years ago

Attachment: site_leftbox.html added

Menu on the left

by Remy Blank, 9 years ago

Attachment: site_newticket.cs added

Notice at the top of the "new ticket" page

comment:4 by Remy Blank, 9 years ago

Owner: changed from Remy Blank to Itamar Ostricher

There you go. There is no site_rightbox.html, even though it's referenced by site.html.

I have removed the stuff related to Google ads and analytics from the templates, but if you need it, you can get it from the HTML here. The same applies to the image files, which you can get here.

Your turn!

by Itamar Ostricher, 9 years ago

Attachment: admin-page-winxp-chrome.PNG added

quirk in admin page with t.e.o layout using Chrome & WinXP

by Itamar Ostricher, 9 years ago

Attachment: admin-page-win7-chrome.png added

quirk in admin page with t.e.o layout using Chrome and Firefox3 with Win7 or IE8 with WinXP

comment:5 by Itamar Ostricher, 9 years ago

Ok, I managed to reproduce the layout on my setup, during which I noticed that if a Trac-env using this layout doesn't have header_logo defined (which is my case) the env-name will be positioned erroneously, so I added a workaround to projects.css:

#header h1 { position: absolute; left: 120px; top: -30px; font-size: 42px; }

(let me know if I could do something better, as I'm not too fluent in the ways of CSS)

Another thing that came up - it seems that the layout of the admin panels with this template is quirky:

  • In the admin-page-winxp-chrome.PNG screenshot, the tabs div is not displayed correctly and the tabcontent div (not shown in screenshot) appears below instead of to the right.
  • In the admin-page-win7-chrome.png screenshot the tabs and tabcontent div's seem fine, except that the tabs div extends beyond the bottom of the "main section" (where I would expect to see the section itself being extended).

Of course I have no way to verify the quirks on the real t.e.o, since I have no admin permissions.

comment:6 by Itamar Ostricher, 9 years ago

See CookBook/TracLayoutRecipe (not closing the ticket because waiting for input on comment:5)

comment:7 by Ryan J Ollos, 5 years ago

Cc: Ryan J Ollos added

Following a discussion of the recipe in gdiscussion:trac-users:TO6UsYAW3VU, I found some minor revisions to the templates that could be made, including updates for styling in Trac 1.0. It would be easier to update the files if they were places in branches/0.12-stable/contrib, and then merged to the other branches and updated as necessary to account for differences in Trac versions. We could add a download link to CookBook/TracLayoutRecipe that points directly to the repository. Any thoughts on whether that should be done?

Last edited 5 years ago by Ryan J Ollos (previous) (diff)

comment:8 by Ryan J Ollos, 5 years ago

The CookBook/TracLayoutRecipe files have been added to contrib in log:rjollos.git:t9629. I plan to test with 0.12-stable, 1.0-stable and trunk, adjusting the style as needed for each.

comment:9 by Ryan J Ollos, 5 years ago

Cc: Ryan J Ollos removed
Milestone: not applicable1.1.5
Owner: changed from Itamar Ostricher to Ryan J Ollos
Status: newassigned

I'll just target the trunk.

comment:10 by Ryan J Ollos, 4 years ago

Milestone: 1.1.51.1.6

comment:11 by Ryan J Ollos, 4 years ago

Milestone: 1.1.6next-dev-1.1.x
Owner: Ryan J Ollos removed
Status: assignednew

comment:12 by Ryan J Ollos, 4 years ago

Milestone: next-dev-1.1.xnext-dev-1.3.x

Narrowing focus for milestone:1.2. Please move ticket to milestone:1.2 if you intend to fix it.

comment:13 by Ryan J Ollos, 2 years ago

Milestone: next-dev-1.3.x
Resolution: fixed
Status: newclosed

If anyone wants the latest templates and stylesheets please ask and I'll attach them to this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to as closed The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.