Edgewall Software
Modify

Opened 11 years ago

Closed 9 years ago

Last modified 9 years ago

#9620 closed defect (duplicate)

TitleIndex is not able to handle numbers / digits

Reported by: Daniel Andersson <daniel@…> Owned by:
Priority: normal Milestone:
Component: wiki system Version: 0.11.7
Severity: normal Keywords: wiki, TitleIndex, title index, numbers, digits
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

The TitleIndex macro doesn't seem to be able to generate headings with digits / numbers in them.

For example, the pages below:

SomethingSomethingFirst
SomethingSomethingFirstFourth
SomethingSomethingFirstOne
SomethingSomethingFirstSecond
SomethingSomethingFirstThird
SomethingSomethingFirstTwo
SomethingSomethingFourth
SomethingSomethingSecond
SomethingSomethingThird
Something123SomethingFirst
Something123SomethingFirstFourth
Something123SomethingFirstOne
Something123SomethingFirstSecond
Something123SomethingFirstThird
Something123SomethingFirstTwo
Something123SomethingFourth
Something123SomethingSecond
Something123SomethingThird

Are indexed as:

  • Something
    • Something
      • First
        • SomethingSomethingFirst
          • SomethingSomethingFirstFourth
          • SomethingSomethingFirstOne
          • SomethingSomethingFirstSecond
          • SomethingSomethingFirstThird
          • SomethingSomethingFirstTwo
      • SomethingSomethingFourth
      • SomethingSomethingSecond
      • SomethingSomethingThird
    • 1
      • Something123SomethingFirst
      • Something123SomethingFirstFourth
      • Something123SomethingFirstOne
      • Something123SomethingFirstSecond
      • Something123SomethingFirstThird
      • Something123SomethingFirstTwo
      • Something123SomethingFourth
      • Something123SomethingSecond
      • Something123SomethingThird

The title for 123 is cut off and the subtitle First isn't generated at all.



I'm running:

  • Trac 0.11.7-4 on Debian Squeeze (Testing)

Plugins from Debian repository:

  • trac-accountmanager
  • trac-wikirename
  • python-setuptools

Manually installed package:

  • PermRedirectPlugin



Best Regards,
Daniel Andersson

Attachments (0)

Change History (5)

comment:1 by Remy Blank, 11 years ago

Milestone: next-minor-0.12.x

There are a few pending issues with the [[TitleIndex]] macro.

comment:2 by Daniel Andersson <daniel@…>, 11 years ago

Too bad then. I'm using Debian and 0.12 isn't even available in Unstable. From what I can Google, it won't be any available in Debian Squeeze (Testing): http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=563391

I'll have to skip the TitleIndex group feature all to together. But thanks for a great product and keep up the good work!

comment:3 by Peter Suter, 10 years ago

This seems to work correctly now, possibly since [10908] / #8925.

Close as worksforme, fixed or duplicate?

in reply to:  3 comment:4 by Jun Omae, 9 years ago

Resolution: duplicate
Status: newclosed

Replying to psuter:

This seems to work correctly now, possibly since [10908] / #8925.

I just confirmed with 0.12-stable [11092]. Works fine.

Close as worksforme, fixed or duplicate?

Yes, closes as a duplicate of #8925.

comment:5 by Christian Boos, 9 years ago

Milestone: next-minor-0.12.x

Great, thanks for checking! I forgot about this one (and probably many others on next-minor-0.12.x…)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.