Edgewall Software
Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#9613 closed defect (duplicate)

Trac detected an internal error:

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: general Version:
Severity: normal Keywords:
Cc: Branch:
Release Notes:
API Changes:

Description (last modified by Christian Boos)

Was performing a custom query at:

http://www.virtualbox.org/query

with:

  • "Type" "is" "defect"
  • "Priority" "is" "Major"
  • "Group results by Priority" with "descending" checkbox checked, then Trac error with Python traceback below:

Python Traceback

Traceback (most recent call last):
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "/var/lib/python-support/python2.5/trac/web/main.py", line 183, in dispatch
    req.perm = PermissionCache(self.env, req.authname)
  File "/var/lib/python-support/python2.5/trac/perm.py", line 263, in __init__
    self.perms = PermissionSystem(env).get_user_permissions(username)
  File "/var/lib/python-support/python2.5/trac/perm.py", line 227, in get_user_permissions
    for perm in self.store.get_user_permissions(username):
  File "/var/lib/python-support/python2.5/trac/perm.py", line 109, in get_user_permissions
    db = self.env.get_db_cnx()
  File "/var/lib/python-support/python2.5/trac/env.py", line 182, in get_db_cnx
    return DatabaseManager(self).get_connection()
  File "/var/lib/python-support/python2.5/trac/db/api.py", line 75, in get_connection
    return self._cnx_pool.get_cnx(self.timeout or None)
  File "/var/lib/python-support/python2.5/trac/db/pool.py", line 109, in get_cnx
    % timeout)
TimeoutError: Unable to get database connection within 20 seconds

Attachments (0)

Change History (2)

comment:1 by Christian Boos, 9 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #9111, tell'em to upgrade to 0.12.1 when it's out ;-)

comment:2 by Christian Boos, 9 years ago

Description: modified (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.