Edgewall Software
Modify

Opened 12 years ago

Closed 12 years ago

#9551 closed defect (worksforme)

Error: Invalid milestone name

Reported by: ianmlewis@… Owned by:
Priority: normal Milestone:
Component: admin/console Version: 0.12-stable
Severity: normal Keywords: needinfo
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

After entering a milestone which contains non-ascii characters (such as Japanese) using the Trac admin, the milestone is entered properly, but cannot be edited.

The milestone is displayed in the list of milestones, however, when clicking on the name of the milestone an error is displayed:

Error: Invalid milestone name Milestone XXXXX does not exist.

The milestone is name is removed here, but it contains escaped url characters such as %ad

Attachments (0)

Change History (4)

comment:1 by Remy Blank, 12 years ago

Keywords: needinfo added

It's working fine here with accented characters and tracd. Could you please tell us which web fontend you are using? Are you using a proxy, or a special setup like proxying through nginx?

Also, could you please paste a milestone name here that fails on your setup?

comment:2 by ianmlewis@…, 12 years ago

We aren't using anything particularly special either. We're simply running tracd on port 4000.

The particular text that failed for me was 'BECKキャンペーン'

in reply to:  2 comment:3 by Christian Boos, 12 years ago

Replying to ianmlewis@…:

We aren't using anything particularly special either. We're simply running tracd on port 4000.

… via an ajp proxy? Try the -q option (see TracStandalone#Reference). This sounds like a duplicate of #8128.

comment:4 by ianmlewis@…, 12 years ago

Resolution: worksforme
Status: newclosed

aha, Apparently it was running behind fastcgi with an incorrect setup. I didn't set it up so I didn't know it was going though the fastcgi layer.

Sorry for the ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.