Edgewall Software
Modify

Opened 17 years ago

Closed 16 years ago

#954 closed defect (fixed)

email notification won't work ?

Reported by: linux@… Owned by: Emmanuel Blot
Priority: normal Milestone: 0.10
Component: ticket system Version: 0.9.4
Severity: major Keywords: notification email
Cc: gsymons@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

the maillog says (FreeBSD4.10)

did not issue MAIL/EXPN/VRFY/ETRN

Attachments (1)

notify-only-if-recipients.patch (689 bytes ) - added by anonymous 16 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 by anonymous, 16 years ago

Milestone: 0.9

comment:2 by Christopher Lenz, 16 years ago

Component: generalticket system
Milestone: 0.9

Please don't set the milestone if you don't also provide a patch or more information.

comment:3 by syncops@…, 16 years ago

Severity: normalmajor
Summary: email notification won't work with sendmailemail notification won't work ?
Version: 0.80.8.4

Getting the same error here when creating/updating tickets. Using freeBSD 5.4. Is this going to work before 0.9 ?

My config

[notification] smtp_enabled = true smtp_replyto = <myemail> smtp_always_cc = smtp_server = localhost smtp_from = <myemail> always_notify_reporter = false

Traceback from tracd:

File "/usr/local/lib/python2.4/SocketServer.py", line 463, in process_request_th read

self.finish_request(request, client_address)

File "/usr/local/lib/python2.4/SocketServer.py", line 254, in finish_request

self.RequestHandlerClass(request, client_address, self)

File "/usr/local/lib/python2.4/SocketServer.py", line 521, in init

self.handle()

File "/usr/local/lib/python2.4/BaseHTTPServer.py", line 314, in handle

self.handle_one_request()

File "/usr/local/lib/python2.4/BaseHTTPServer.py", line 308, in handle_one_reque st

method()

File "/usr/local/bin/tracd", line 216, in do_POST

self.do_trac_req()

File "/usr/local/bin/tracd", line 238, in do_trac_req

trac.core.send_pretty_error(e, self.env, self)

File "/usr/local/lib/python2.4/site-packages/trac/core.py", line 500, in send_pr etty_error

req.send_response(500)

File "/usr/local/lib/python2.4/BaseHTTPServer.py", line 364, in send_response

self.wfile.write("%s %d %s\r\n" %

File "/usr/local/lib/python2.4/socket.py", line 256, in write

self.flush()

File "/usr/local/lib/python2.4/socket.py", line 243, in flush

self._sock.sendall(buffer)

error: (32, 'Broken pipe')

comment:4 by gsymons@…, 16 years ago

I've got the same problem here. Here's my trac.ini:

[notification]
smtp_enabled = TRUE
smtp_replyto = noreply@gsconsulting.biz
smtp_always_cc =
smtp_server = smtp.gsconsulting.biz
smtp_from = trac@teambc.gsconsulting.biz
always_notify_reporter = TRUE

I'm running on linux here, with Trac 8.4 and python 2.3.5. I did a tcpdump of an attempt to send a notification, and basically it looks like it connects, does nothing, and sends an SMTP QUIT command. I can't see anything in the code that would make it do this… it's all a mystery.

comment:5 by anonymous, 16 years ago

Cc: gsymons@… added

comment:6 by anonymous, 16 years ago

A clue perhaps: I ran into the same problem until I used email addresses that contain a '@' character.

comment:7 by anonymous, 16 years ago

I just got this error. It was caused by me not understanding how the notification works. I had assumed if it has my name ("bob") in the "your email or username" field, then I would get notified - seeing as I had already set my email address on the preferences page. But in fact the the username is not sufficient for notification purposes, hence no email got sent.

I do suggest, however, that the email handling shouldn't even bother opening an SMTP connection at all if there are no recipients, thus preventing log turds - see patch attached.

by anonymous, 16 years ago

comment:8 by anonymous, 16 years ago

Keywords: notification email added

comment:9 by stynor+trac@…, 16 years ago

Version: 0.8.40.9.4

I just fixed a related configuration error on my 0.9.4 Trac install: I'd created a local trac-watchers aliase and set:

smtp_always_notify = trac-watchers

this results in no error, no warning, and no notifications. Changing that to

smtp_always_notify = trac-watchers@localhost

fixes this. However, It would be MUCH nicer if Trac would allow 'local' user names in the config file, and in the requestors/submitters fields.

comment:10 by anonymous, 16 years ago

typo in my previous post: that's smtp_always_cc not smtp_always_notify.

comment:11 by Emmanuel Blot, 16 years ago

Milestone: 0.10
Owner: changed from Jonas Borgström to Emmanuel Blot
Status: newassigned

Since [3337], Trac accepts local user names if the use_short_addr is defined. See also the smtp_default_domain option if your local SMTP server does not accept address without a FQDN (fully qualified domain name).

The patch cannot be used as-is, as the notification code has changed quit a bit for 0.10.

However, it should be possible to open a connection to the SMTP server, HELO it, and simply QUIT without generating an error.

comment:12 by Emmanuel Blot, 16 years ago

Resolution: fixed
Status: assignedclosed

Should be fixed in [3338].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Emmanuel Blot.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from Emmanuel Blot to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.