Edgewall Software
Modify

Opened 11 years ago

Closed 11 years ago

#9525 closed defect (duplicate)

AttributeError: 'NoneType' object has no attribute 'keys'

Reported by: mcpbalaji@… Owned by: mcpbalaji@…
Priority: high Milestone:
Component: general Version: 0.11
Severity: critical Keywords:
Cc: mcpbalaji@… Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /admin/accounts/groups, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'cat_id': u'accounts', 'panel_id': u'groups', 'path_info': None}

User Agent was: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121911 CentOS/3.0.5-1.el5.centos Firefox/3.0.5

System Information

Trac 0.11
Python 2.4.3 (#1, Sep 3 2009, 15:37:12)
[GCC 4.1.2 20080704 (Red Hat 4.1.2-46)]
setuptools 0.6c11
SQLite 3.3.6
pysqlite 2.3.3
Genshi 0.6
mod_python 3.2.8
Subversion 1.6.12 (r955767)
jQuery: 1.2.3

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/web/main.py", line 423, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/web/main.py", line 197, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/admin/web_ui.py", line 109, in process_request
    path_info)
  File "build/bdist.linux-i686/egg/htgroupeditor/htgroupeditor.py", line 145, in render_admin_panel
AttributeError: 'NoneType' object has no attribute 'keys'

Attachments (0)

Change History (1)

comment:1 by Remy Blank, 11 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #9524.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain mcpbalaji@….
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from mcpbalaji@… to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.