Edgewall Software
Modify

Opened 10 years ago

Closed 10 years ago

#9476 closed defect (duplicate)

ValueError: timestamp out of range for platform time_t

Reported by: asim.moxme@… Owned by:
Priority: highest Milestone:
Component: general Version: 0.12
Severity: blocker Keywords:
Cc: Branch:
Release Notes:
API Changes:
Internal Changes:

Description

How to Reproduce

While doing a GET operation on /ticket/xxxx, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'id': u'1689'}

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6

System Information

Trac 0.12
Python 2.4.3 (#1, Sep 3 2009, 15:37:12)
[GCC 4.1.2 20080704 (Red Hat 4.1.2-46)]
setuptools 0.6c9
SQLite 3.3.6
pysqlite 2.6.0
Genshi 0.6
mod_python 3.2.8
Subversion 1.4.2 (r22196)
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2-py2.4.egg/trac/web/main.py", line 432, in _dispatch_request
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2-py2.4.egg/trac/web/main.py", line 204, in dispatch
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2-py2.4.egg/trac/ticket/web_ui.py", line 181, in process_request
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2-py2.4.egg/trac/ticket/web_ui.py", line 530, in _process_ticket_request
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2-py2.4.egg/trac/ticket/web_ui.py", line 1187, in _insert_ticket_data
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2-py2.4.egg/trac/ticket/web_ui.py", line 1285, in rendered_changelog_entries
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2-py2.4.egg/trac/ticket/web_ui.py", line 1365, in grouped_changelog_entries
  File "/usr/lib/python2.4/site-packages/Trac-0.11.2-py2.4.egg/trac/ticket/model.py", line 334, in get_changelog
ValueError: timestamp out of range for platform time_t

Attachments (0)

Change History (1)

comment:1 by Remy Blank, 10 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #9403. Your system information says 0.12, but the traceback mentions a 0.11.2 egg. Uninstall 0.11.2 completely.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
to The owner will be changed from (none) to the specified user.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.